现在的位置: 首页 > 综合 > 正文

贪心字典序最小问题poj3617

2017年06月07日 ⁄ 综合 ⁄ 共 2002字 ⁄ 字号 评论关闭
Best Cow Line
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10605   Accepted: 3189

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase
ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's
finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source

题意:给定长度为n的str字符串 要构筑一个新的字符串t,开始t是个空串
两个操作:
1.将第一个字符加在新字符串尾部

2.将最后一个字符加在新串尾部

使得新串最小

ps; 每80为一个新串

字典序:是指从前到后比较两个字符串大小的方法。首先比较第一个字符大小,如果不同则第一个字符小的字符串更小,如果相同则比较第二个、、、

如此继续。。比较谁大谁小

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;

char str[3005];
int n;
void solve()
{
    int a = 0,b=n-1;
    int cnt=0;
    while(a<=b)
    {
        bool left = true ;
        for(int i=0; a+i<=b; i++)
        {
            if(str[i+a]<str[b-i])
            {
                left = true ;
                break;
            }
            else if(str[i+a]>str[b-i])
            {
                left = false;
                break;
            }
        }
        if(left)
            putchar(str[a++]);
        else
            putchar(str[b--]);
        cnt++;
        if(cnt==80)
        {
            cout<<endl;
            cnt=0;
        }
    }
    cout<<endl;
}
int main()
{
    while(cin>>n)
    {
        for(int i=0;i<n;i++) cin>>str[i];

        str[n]='\0';
        solve();
    }
}

抱歉!评论已关闭.