现在的位置: 首页 > 综合 > 正文

Moving Tables

2017年07月16日 ⁄ 综合 ⁄ 共 2421字 ⁄ 字号 评论关闭

Moving Tables

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 1

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains
two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

这一题一直错了七八次,还是看师傅代码才知道自己的解题方向错了

题目大意是,房间布置 如同第一个表格(第二个表格没什么用),经理需要移动桌子(移动一次十分钟),    桌子可以同时移动(条件允许一次移动完毕也可以),但是不能共用走廊(形如表格一),问移动所有桌子最短所需的时间。

粘贴代码,如下:

/*
   解题思路,找出每组测试数据中,经过每个房间的次数,
   则桌子经过最多的那个房间的次数乘以10就等于移动桌子
   所需要最短的时间。 
*/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

int cmp(int a,int b)
{
	return a>b;
}

int main()
{
	int T,n,i,j,s,t,c,a[450];
	scanf("%d",&T);
	while(T--)
	{
		memset(a,0,sizeof(a));/*将数组所有数初始化为零,
		 即将所有房间被经过的次数初始化为零*/ 
		scanf("%d",&n);          
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&s,&t);
			if(s>t)/*无论开始的房间号大还是目的地房间号大,都可以
			看做从号码小的房间出发*/ 
			{
				c=s;
				s=t;
				t=c;
			}
			if(s%2==0)//考虑实际情况出发房间号为偶数时,求经过房间时应减一 
			  s=s-1;
			if(t&1)//目的地房间号为奇数时应加一 
			  t=t+1;
			for(j=s;j<=t;j++)
			  a[j]++;
		}
		sort(a,a+450,cmp);
		printf("%d\n",a[0]*10);
	}
	return 0;
}


【上篇】
【下篇】

抱歉!评论已关闭.