现在的位置: 首页 > 综合 > 正文

Let the Balloon Rise

2017年07月23日 ⁄ 综合 ⁄ 共 1325字 ⁄ 字号 评论关闭

Let the Balloon Rise

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 8

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink
题很水,但是英文题最重要的还是弄得题意,英语渣渣也是对它跪了大哭。  
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char str[1100][20];
int main()
{
	int n,i,j,a[1100],max;
	while(scanf("%d",&n),n)
	{
		max=0;//注意将max于for循环外初始化 
		for(i=0;i<n;i++)
		  scanf("%s",str[i]);
		for(i=0;i<n;i++)
		{
			a[i]=0;
			for(j=i+1;j<n;j++)
			{
				if(strcmp(str[i],str[j])==0)
				
					  a[i]++;
			}
			if(a[i]>max)
			   max=a[i];
		}
		for(i=0;i<n;i++)
		{
			if(max==a[i])
			  printf("%s\n",str[i]);
		}
	}
	//system("pause");
	return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.