现在的位置: 首页 > 综合 > 正文

POJ 1845 Sumdiv

2017年10月11日 ⁄ 综合 ⁄ 共 1740字 ⁄ 字号 评论关闭

Sumdiv

Description

Consider two natural numbers A and B. Let S be the sum of all natural divisors of A^B. Determine S modulo 9901 (the rest of the division of S by 9901).

Input

The only line contains the two natural numbers A and B, (0 <= A,B <= 50000000)separated by blanks.

Output

The only line of the output will contain S modulo 9901.

Sample Input

2 3

Sample Output

15

Hint

2^3 = 8.
The natural divisors of 8 are: 1,2,4,8. Their sum is 15.
15 modulo 9901 is 15 (that should be output).
 
 
两个重要的结论:

约数和公式:

对于已经分解的整数A=(p1^k1)*(p2^k2)*(p3^k3)*....*(pn^kn)

有A的所有因子之和为

    S = (1+p1+p1^2+p1^3+...p1^k1) * (1+p2+p2^2+p2^3+….p2^k2) * (1+p3+ p3^3+…+ p3^k3) * .... * (1+pn+pn^2+pn^3+...pn^kn)

 

用递归二分求等比数列1+pi+pi^2+pi^3+...+pi^n:

一、若n为奇数,一共有偶数项,则:
      1 + p + p^2 + p^3 +...+ p^n

      = (1+p^(n/2+1)) + p * (1+p^(n/2+1)) +...+ p^(n/2) * (1+p^(n/2+1))  

     这里将其分成两半,提后一半的公因式p^(n/2+1)
      = (1 + p + p^2 +...+ p^(n/2)) * (1 + p^(n/2+1))

二、若n为偶数,一共有奇数项,则:
      1 + p + p^2 + p^3 +...+ p^n

      = (1+p^(n/2+1)) + p * (1+p^(n/2+1)) +...+ p^(n/2-1) * (1+p^(n/2+1)) + p^(n/2)

     可知n-1为偶数,对前偶数项进行上述操作再加上最后一项p^n
      = (1 + p + p^2 +...+ p^(n/2-1)) * (1+p^(n/2)) + p^n;

 

AC代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define mod 9901
#define M 10000
#define ll long long
using namespace std;

ll power(ll d,ll p)//幂次的优化
{
    ll ans=1;
    while(p>0)
    {
        if(p%2)
            ans=(ans*d)%mod;
        p/=2;
        d=(d*d)%mod;
    }
    return ans;
}

ll sum(ll d,ll p)//等比数列求和递归
{
    if(p==0)
        return 1;
    if(p==1)
        return 1+d;
    if(p%2==1)
        return sum(d,p/2)*(1+power(d,p/2+1))%mod;
    else return (sum(d,p/2-1)*(1+power(d,p/2))%mod+power(d,p))%mod;
}

int main()
{
    int i,j;
    int a,b;
    while(~scanf("%d%d",&a,&b))
    {
        int ds[M];
        int po[M];
        int tt=0;
        for(i=2;i*i<=a;)//求a的因子
        {
            if(a%i==0)
            {
                ds[tt]=i;
                po[tt]=0;
                while(!(a%i))
                {
                    po[tt]++;
                    a/=i;
                }
                tt++;
            }
            i==2?i++:i+=2;
        }
        if(a!=1)
        {
            ds[tt]=a;
            po[tt++]=1;
        }
        ll ans = 1;
        for(i=0;i<tt;i++)
            ans=(ans*(ll)sum(ds[i],po[i]*b))%mod;
        printf("%I64d\n",ans);
    }
}

 

【上篇】
【下篇】

抱歉!评论已关闭.