现在的位置: 首页 > 综合 > 正文

【HDU】2222 Keywords Search AC自动机

2017年10月15日 ⁄ 综合 ⁄ 共 2528字 ⁄ 字号 评论关闭

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32471    Accepted Submission(s): 10501

Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 


Input

First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 


Output

Print how many keywords are contained in the description.
 


Sample Input
1 5 she he say shr her yasherhs
 


Sample Output
3
 


Author

Wiskey

传送门:【HDU】2222 Keywords Search

题目大意:给你多个模式串,问能在目标串中匹配多少个。

题目分析:
AC自动机模板题,因为忘记考虑模式串重复的问题差点成WA自动机= =||
注意本题搜过的就不用再搜一次了,反正都标记为0了

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

#define REP( I , N ) for ( int I = 0 ; I < N ; ++ I )
#define CHARREP( I ) for ( int I = 0 ; buf[I] ; ++ I )
#define clear( A , X ) memset ( A , X , sizeof A )

const int maxW = 26 ;
const int maxN = 10005 ;
const int TIME = 55 ;
const int maxS = 1000005 ;
const int maxQ = 1000005 ;

struct Trie {
	int next[maxN * TIME][maxW] ;
	int fail[maxN * TIME] ;
	int end[maxN * TIME] ;
	int Q[maxQ] ;
	int head , tail ;
	int P , root ;
	bool vis[maxN * TIME] ;
	
	int New () {
		REP ( i , maxW ) next[P][i] = -1 ;
		end[P] = 0 ;
		return P ++ ;
	}//New
	
	void Init () {
		P = 0 ;
		root = New () ;
	}//Init
	
	void Insert ( char buf[] ) {
		int now = root ;
		CHARREP ( i ) {
			int x = buf[i] - 'a' ;
			if ( next[now][x] == -1 ) next[now][x] = New () ;
			now = next[now][x] ;
		}
		end[now] ++ ;
	}//Insert
	
	void Build () {
		head = tail = 0 ;
		fail[root] = root ;
		REP ( i , maxW ) {
			if ( next[root][i] == -1 ) next[root][i] = root ;
			else {
				fail[next[root][i]] = root ;
				Q[tail ++] = next[root][i] ;
			}
		}
		while ( head != tail ) {
			int now = Q[head ++] ;
			if ( head >= maxQ ) head -= maxQ ;
			REP ( i , maxW ) {
				if ( next[now][i] == -1 ) next[now][i] = next[fail[now]][i] ;
				else {
					fail[next[now][i]] = next[fail[now]][i] ;
					Q[tail ++] = next[now][i] ;
					if ( tail >= maxQ ) tail -= maxQ ;
				}
			}
		}
	}//Build
	
	void Query ( char buf[] ) {
		int now = root , res = 0 ;
		clear ( vis , 0 ) ;
		CHARREP ( i ) {
			now = next[now][buf[i] - 'a'] ;
			int tmp = now ;
			while ( tmp != root ) {
				if ( vis[tmp] ) break ;
				vis[tmp] = 1 ;
				res += end[tmp] ;
				tmp = fail[tmp] ;
			}
		}
		printf ( "%d\n" , res ) ;
	}//Query
} ;

Trie AC ;
char buf[maxS] ;

void Work () {
	int n ;
	AC.Init () ;
	scanf ( "%d" , &n ) ;
	REP ( i , n ) {
		scanf ( "%s" , buf ) ;
		AC.Insert ( buf ) ;
	}
	AC.Build () ;
	scanf ( "%s" , buf ) ;
	AC.Query ( buf ) ;
}//Work

int main () {
	int T ;
	scanf ( "%d" , &T ) ;
	while ( T -- ) Work () ;
	return 0 ;
}//main


抱歉!评论已关闭.