现在的位置: 首页 > 综合 > 正文

poj2201Cartesian Tree(笛卡尔树)

2017年12月13日 ⁄ 综合 ⁄ 共 2785字 ⁄ 字号 评论关闭
Cartesian Tree
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 2950   Accepted: 1122
Case Time Limit: 2000MS

Description

Let us consider a special type of a binary search tree, called a cartesian tree. Recall that a binary search tree is a rooted ordered binary tree, such that for its every node x the following condition is satisfied: each node in its left subtree has the key
less then the key of x, and each node in its right subtree has the key greater then the key of x. 
That is, if we denote left subtree of the node x by L(x), its right subtree by R(x) and its key by kx then for each node x we have 
  • if y ∈ L(x) then ky < kx 
  • if z ∈ R(x) then kz > kx

The binary search tree is called cartesian if its every node x in addition to the main key kx also has an auxiliary key that we will denote by ax, and for these keys the heap condition is satisfied, that is 

  • if y is the parent of x then ay < ax

Thus a cartesian tree is a binary rooted ordered tree, such that each of its nodes has a pair of two keys (k, a) and three conditions described are satisfied. 
Given a set of pairs, construct a cartesian tree out of them, or detect that it is not possible.

Input

The first line of the input file contains an integer number N -- the number of pairs you should build cartesian tree out of (1 <= N <= 50 000). The following N lines contain two numbers each -- given pairs (ki, ai). For each pair |ki|, |ai| <= 30 000. All main
keys and all auxiliary keys are different, i.e. ki != kj and ai != aj for each i != j.

Output

On the first line of the output file print YES if it is possible to build a cartesian tree out of given pairs or NO if it is not. If the answer is positive, on the following N lines output the tree. Let nodes be numbered from 1 to N corresponding to pairs they
contain as they are given in the input file. For each node output three numbers -- its parent, its left child and its right child. If the node has no parent or no corresponding child, output 0 instead. 
The input ensure these is only one possible tree.

Sample Input

7
5 4
2 2
3 9
0 5
1 3
6 6
4 11

Sample Output

YES
2 3 6
0 5 1
1 0 7
5 0 0
2 4 0
1 0 0
3 0 0

Source

Northeastern Europe 2002, Northern Subregion
题目大意:裸的笛卡尔树,建树输出每个点的父节点和儿子节点编号,没有为0。
题目分析:注意这题肯定要输出YES,因为给的每一对关键字都不相同,所以能建唯一的笛卡尔树,不存在NO的情况。还有排序后序号就乱了,注意一下就行了,其他的没什么了。
详情请见代码:
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 50005;
struct node
{
    int key,val;
    int l,r,pa,id;
}lcm[N];
int pp[N],ll[N],rr[N];
int n;
int stack[N];
int cmp(struct node a,struct node b)
{
    return a.key < b.key;
}
int cmp2(struct node a,struct node b)
{
    return a.id < b.id;
}

void build()
{
    int i,j,top;
    top = -1;
    for(i = 1;i <= n;i ++)
    {
        j = top;
        while(j >= 0 && lcm[stack[j]].val > lcm[i].val)
        {
            j --;
        }
        if(j != -1)
        {
            pp[lcm[i].id] = lcm[stack[j]].id;
            rr[lcm[stack[j]].id] = lcm[i].id;
        }
        if(j < top)
        {
            pp[lcm[stack[j + 1]].id] = lcm[i].id;
            ll[lcm[i].id] = lcm[stack[j + 1]].id;
        }
        stack[++ j] = i;
        top = j;
    }
}

int main()
{
    int i;
    while(scanf("%d",&n) != EOF)
    {
        for(i = 1;i <= n;i ++)
        {
            scanf("%d%d",&lcm[i].key,&lcm[i].val);
            lcm[i].l = lcm[i].r = lcm[i].pa = 0;
            lcm[i].id = i;
        }
        lcm[0].id = 0;
        sort(lcm + 1,lcm + 1 + n,cmp);
        memset(pp,0,sizeof(pp));
        memset(ll,0,sizeof(ll));
        memset(rr,0,sizeof(rr));
        build();
        printf("YES\n");
        for(i = 1;i <= n;i ++)
            printf("%d %d %d\n",pp[i],ll[i],rr[i]);
    }
    return 0;
}
//2124K	1016MS

抱歉!评论已关闭.