现在的位置: 首页 > 综合 > 正文

POJ 3723 Conscription

2018年01月12日 ⁄ 综合 ⁄ 共 1969字 ⁄ 字号 评论关闭
Conscription
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6325   Accepted: 2184

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some
relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB.
Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

题意:征兵:有n个女生,m个男生,其中每个人需要花费10000元。不过男生和女生之间有相互作用,可以降低费用。比如编号为1的女生和编号为1的男生之间有关系d,那么女生已经征兵结束后,男生只需10000-d即可入伍

这道题讲的很玄乎,其实就是最小生成树。我一开始还把男生女生分别对待,即每次贪心得到最小值时,分别用男生对女生的关系和女生对男生的关系来得到最小值,然后再取。采用了prime来做。这样确实可以做,不过男生女生数量大,超内存了。

其实仔细想一想,男生女生是图中相同类型的点,只不过只有男生和女生之间才有路连通。所以用krusical来做,每次取最小值加入。和最小生成树一模一样

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int n,m;
struct node
{
    int x,y,s;
}e[50010];
int f[20010];
int find(int x)
{
    return (f[x]==x? x:f[x]=find(f[x]));
}
bool cmp(node s, node v)
{
    return s.s>v.s;
}
void krusical(int p)
{
    int i,j,ans=0;
    for (i=0; i<p; i++)
    {
        int x=find(e[i].x);
        int y=find(e[i].y);
        if (x!=y)
        {
            ans+=e[i].s;
            f[x]=f[y];
        }
    }
    cout<<10000*(n+m)-ans<<endl;
}
int main ()
{
    int i,j,t,r,s;
    cin>>t;
    while(t--)
    {
        int p=0;
        cin>>n>>m;
        for (i=0; i<=n+m; i++)
            f[i]=i;
        cin>>r;
        while(r--)
        {
            scanf("%d%d%d",&e[p].x,&j,&e[p].s);
            e[p++].y=j+n;
        }
        sort(e,e+p,cmp);
        krusical(p);
    }
    return 0;
}

抱歉!评论已关闭.