现在的位置: 首页 > 综合 > 正文

poj2352 stars

2018年01月13日 ⁄ 综合 ⁄ 共 2630字 ⁄ 字号 评论关闭
Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32858   Accepted: 14352

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

好久不打线段树……都不会打了

这题很坑……坐标范围是[0,32000]不是1到32000……简直……坑了我三个小时(不过那些写树状数组的有0怎么办呢hhhhhhh)

首先按y坐标为第一关键字x为第二关键字排序。然后用线段树维护横坐标为1到x的点有多少个。因为y是升序的,所以一定保证yi>=yj

#include<cstdio>
#include<algorithm>
using namespace std;
#define N 100010
#define MAXx 50010
struct stars{
	int x,y;
}s[N];
inline bool cmp(const stars &a,const stars &b)
{return a.y<b.y||a.y==b.y&&a.x<b.x;}
struct segtree{
	int l,r,sum;
}tree[10*MAXx];
int n;
int ans[2*N];
inline int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
inline void buildtree(int now,int l,int r)
{
	tree[now].l=l;tree[now].r=r;
	if (l==r)return;
	int mid=(l+r)>>1;
	buildtree(now<<1,l,mid);
	buildtree(now<<1|1,mid+1,r);
}
inline void insert(int now,int d)
{
	int x=tree[now].l,y=tree[now].r;
	tree[now].sum++;
	if (x==y)return;
	int mid=(x+y)>>1;
	if (d<=mid)insert(now<<1,d);
	else if (d>mid)insert(now<<1|1,d);
}
inline int query(int k,int l,int r)
{
	int x=tree[k].l,y=tree[k].r;
	if (l==x&&r==y) return tree[k].sum;
	int mid=(x+y)>>1;
	if (r<=mid) return query(k<<1,l,r);
	else if (l>mid) return query(k<<1|1,l,r);
	else return query(k<<1,l,mid)+query(k<<1|1,mid+1,r);
}
int main()
{
	n=read();
	buildtree(1,0,MAXx);
	for(int i=1;i<=n;i++)s[i].x=read(),s[i].y=read();
	sort(s+1,s+n+1,cmp);
	for(int i=1;i<=n;i++)
	  {
	  	int x=s[i].x,y=s[i].y;
	  	ans[query(1,0,x)]++;
	  	insert(1,x);
	  }
	for (int i=0;i<n;i++)
	  printf("%d\n",ans[i]);
}

抱歉!评论已关闭.