现在的位置: 首页 > 综合 > 正文

HDOJ 1892 See you~ 树状数组

2018年01月20日 ⁄ 综合 ⁄ 共 2924字 ⁄ 字号 评论关闭

See you~

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3653    Accepted Submission(s): 1156

Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we
could not advanced to the World Finals last year.
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work
is to tell me how many books are stayed in some rectangles.
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position
or bring in one book and put it on one position.
 

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed.

For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries.

There are 4 kind of queries, sum, add, delete and move.
For example:
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.

A x1 y1 n1 means I put n1 books on the position (x1,y1)
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them.

M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them.

Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.
 

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries.

For each "S" query, just print out the total number of books in that area.
 

Sample Input
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2
 

Sample Output
Case 1: 1 3 Case 2: 1 4
/*
HDU 1892 树状数组
这里是二维的 
求对角线的和 就相当于求一个矩阵的面积 
*/

#include<iostream>
#include<stdio.h>
using namespace std;

#define N 1005

int map[N][N];

void add(int x,int y,int d)//d是要增加的值
{
    int i,j;
    for(i=x;i<N;i+=(i&-i))
        for(j=y;j<N;j+=(j&-j)) 
            map[i][j]+=d;    
}

int sum(int x,int y)
{
    int i,j,ans=0;
    for(i=x;i>0;i-=(i&-i))
        for(j=y;j>0;j-=(j&-j))
            ans+=map[i][j];
    return ans;    
}

int main()
{
    int i,j,t,k,a,b,c,d,e,v,n;
    char str[5];
    
    //freopen("test.txt","r",stdin);
    scanf("%d",&t);
    k=1;
    while(t--)
    {
        scanf("%d",&n);
        printf("Case %d:\n",k++);
        
        memset(map,0,sizeof(map));
        //树状数组的坐标是从1开始的,而题中x,y的坐标都是从0开始的,自增1
        for(i=1;i<N;i++)
            for(j=1;j<N;j++)
                add(i,j,1);
        
        while(n--)
        {
            scanf("%s",str);
            if(str[0]=='S')
            {
                scanf("%d%d%d%d",&a,&b,&c,&d);//对角线保证大的在前面 
                if(a<c) swap(a,c);
                if(b<d) swap(b,d);
                printf("%d\n",sum(a+1,b+1)-sum(a+1,d)-sum(c,b+1)+sum(c,d));
            }
            else if(str[0]=='A')
            {
                scanf("%d%d%d",&a,&b,&c);
                add(a+1,b+1,c);
            }
            else if(str[0]=='D')
            {
                scanf("%d%d%d",&a,&b,&c);//有可能出现数量不足的情况
                v=sum(a+1,b+1)-sum(a,b+1)-sum(a+1,b)+sum(a,b);
                c=v<c?v:c;
                add(a+1,b+1,-c);
            }
            else
            {
                scanf("%d%d%d%d%d",&a,&b,&c,&d,&e);
                v=sum(a+1,b+1)-sum(a,b+1)-sum(a+1,b)+sum(a,b);
                e=v<e?v:e;
                add(a+1,b+1,-e);
                add(c+1,d+1,e);
            }
        }    
    }
    return 0;
} 

抱歉!评论已关闭.