现在的位置: 首页 > 综合 > 正文

POJ2253 Frogger (最小生成树之prim)

2018年02月22日 ⁄ 综合 ⁄ 共 2371字 ⁄ 字号 评论关闭
Problem Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming
and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of
stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three
decimals. Put a blank line after each test case, even after the last one.

Sample Input
2 0 0 3 4 3 17 4 19 4 18 5 0

Sample Output
Scenario #1 Frog Distance = 5.000 Scenario #2 Frog Distance = 1.414
最目意思是:从第一个点到第二个点,但以最小权为优先建立,也就是最小生成树,但也有点不同,不是把每个点都放到一棵树上,只要找到了第二个点就结束。
要求的结果是最小生成树中权值最大的一个边。在输出时一定要注意。
#include<stdio.h>
#include<math.h>
typedef struct nn
{
    double dist,x,y;
}Node;
Node node[205];
double map[205][205],max,INF=100000000.0;
int s[205],n;
void set_first()
{
    for(int i=1;i<=n;i++)
    {
        s[i]=0; node[i].dist=INF;
        for(int j=i+1;j<=n;j++)
        map[i][j]=map[j][i]=sqrt(pow(node[i].x-node[j].x,2)+pow(node[i].y-node[j].y,2));
    }
}
void Prim(int m)
{
    double min;
    int tm=m;
    s[m]=1;max=0;
    for(int k=2; k<=n;k++)
    {
        min=INF;
        for(int i=1;i<=n;i++)
        if(s[i]==0)
        {
            if(node[i].dist>map[tm][i])
            node[i].dist=map[tm][i];
            if(min>node[i].dist)
            {
                min=node[i].dist; m=i;
            }

        }
        s[m]=1;tm=m; if(max<node[m].dist) max=node[m].dist;
        if(m==2) break;//到达
    }
}
int main()
{
    int k=1;
    while(scanf("%d",&n)>0&&n)
    {
        for(int i=1;i<=n;i++)
        scanf("%lf%lf",&node[i].x,&node[i].y);
        set_first();
        Prim(1);
        printf("Scenario #%d\n",k++);
        printf("Frog Distance = %.3f\n\n",max);//要用这样的输出,不能用lf
    }
}

抱歉!评论已关闭.