现在的位置: 首页 > 综合 > 正文

poj 2488 A Knight’s Journey

2013年01月16日 ⁄ 综合 ⁄ 共 2275字 ⁄ 字号 评论关闭
A Knight's Journey
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 24580   Accepted: 8309

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

#include <stdio.h>
#include<string.h>
int dx[8]= {-1,1,-2,2,-2,2,-1,1};//按字典顺序走必须这么写
int dy[8]= {-2,-2,-1,-1,1,1,2,2};
int visit[50][50],way[100][2];//visit记录是否访问。way记录路径
int p,q;

int dfs(int x,int y,int r)//x,y记录当前所在位置。r记录下一步为第几步
{
    int nx,ny,i;

    if(r-1==p*q)//如果已经走完则输出
        return 1;
    for(i=0; i<8; i++)
    {
        nx=x+dx[i];
        ny=y+dy[i];
        if(nx<1||nx>p||ny<1||ny>q||visit[nx][ny])
            continue;
        visit[nx][ny]=1;
        way[r][0]=nx;
        way[r][1]=ny;
        if(dfs(nx,ny,r+1))
            return 1;
        visit[nx][ny]=0;
    }
    return 0;
}
int main()
{
    int t,i,k;

    scanf("%d",&t);

    for(k=1; k<=t; k++)
    {
        scanf("%d%d",&p,&q);
        memset(visit,0,sizeof visit);
        way[1][0]=way[1][1]=1;
        visit[1][1]=1;
        printf("Scenario #%d:\n",k);
        if(dfs(1,1,2))
        {
            for(i=1; i<=p*q; i++)
                printf("%c%d",way[i][1]-1+'A',way[i][0]);
            printf("\n");
        }
        else
            printf("impossible\n");
        if(k!=t)
            printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.