现在的位置: 首页 > 综合 > 正文

用java的BigDecimal来做POJ 1001题

2013年08月18日 ⁄ 综合 ⁄ 共 2083字 ⁄ 字号 评论关闭
Exponentiation
Time Limit: 500MS   Memory Limit: 10000K
Total Submissions: 113314   Accepted: 27486

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

/**
 * 功能:poj 1001 题
 * 
 * @author wangchangshuai0010 山东科技大学 2013年2月7日 11:44
 */
package problem1001;

import java.math.BigDecimal;
import java.util.Scanner;

public class Main
{
	/**
	 * @param args
	 */
	public static void main(String[] args)
	{
		Scanner cin = new Scanner(System.in);
		String string = null;
		BigDecimal bigDecimal = null;
		BigDecimal result = null;
		String resultString = null;
		int index;
		while (cin.hasNext())
		{
			result = BigDecimal.valueOf(1);
			string = cin.nextLine();
			double temp = Double.parseDouble(string.substring(0, 6).trim());
			int n = Integer.parseInt(string.substring(7).trim());
			bigDecimal = BigDecimal.valueOf(temp);
			for (int i = 0; i < n; i++)
			{// 进行幂运算
				result = result.multiply(bigDecimal);
			}
			resultString = result.toPlainString();
			index = -1;
			if ((temp == (int) temp)
					&& ((index = resultString.indexOf('.')) != -1))
			{// 判断是不是对整数进行运算
				System.out.println(resultString.substring(0, index));
			}
			else
			{
				if (!resultString.startsWith("0"))
				{// 判断结果是不是是不是0开头
					System.out.println(resultString);
				}
				else
				{// 否则直接输出
					System.out.println(resultString.substring(1));
				}
			}
		}
	}
}

抱歉!评论已关闭.