现在的位置: 首页 > 综合 > 正文

poj2109

2013年09月08日 ⁄ 综合 ⁄ 共 1405字 ⁄ 字号 评论关闭
Power of Cryptography
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 16130   Accepted: 8134

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches
of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is
what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn =
p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234
水题
#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
int main ()
{
	int n,i,len,flag,sum,re;
	char temp[200],temp2[200];
	while(scanf("%d",&n)!=EOF)
	{
	
		getchar();
		gets(temp);
		re=0;
		while(1)
		{
			len=strlen(temp);
			if(len==1&&(temp[0]-'0')<n)
			{
				break;
			}
			flag=0;sum=0;
		for(i=0;i<len;)
		{
			
			while(sum<n)
			{
			
				sum=sum*10+temp[i]-'0';
				i++;
			}
			temp2[flag]=sum/n+'0';
			sum=sum-(temp2[flag]-'0')*n;
			flag++;

		}
		temp2[flag]='\0';
		printf("%s\n",temp2);
		strcpy(temp,temp2);
		re++;


		}
		printf("%d\n",re);
	}

	return 0;
}

抱歉!评论已关闭.