现在的位置: 首页 > 综合 > 正文

hdu4493 Tutor

2013年09月16日 ⁄ 综合 ⁄ 共 1583字 ⁄ 字号 评论关闭

Tutor

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 48 Accepted Submission(s): 27

Problem Description
Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year,
Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.

Input
The first line contain one integer T, means the total number of cases.

Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output
The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters
in the output.

Sample Input
2 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00

Sample Output
$1581.42 $100

Source
大坑题啊,不知道错了多少次了!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int main()
{
    int n,i,m;
    double temp,sum;
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        for(i=0;i<12;i++)
        {
             scanf("%lf",&temp);
            sum+=temp;
        }
        sum=sum/12.0;
        int m=(int)(sum*100);
        int sum0=(int)(sum*1000);
        if(sum0%10>=5)
        m+=1;
        printf("$%d",m/100);
        m=m%100;
        if(m%100==0)
        {
             printf("\n");
        }
        else if(m%10==0)
        {
            printf(".%d\n",m/10);
        }
        else
        {
            if(m<10)
            printf(".0%d\n",m);
            else
            printf(".%d\n",m);
        }
    }
    return 0;
}

抱歉!评论已关闭.