现在的位置: 首页 > 综合 > 正文

HDU OJ 1010 dfs+剪枝

2014年08月29日 ⁄ 综合 ⁄ 共 2436字 ⁄ 字号 评论关闭

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61611    Accepted Submission(s): 16858

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately
to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively.
The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
NO YES
 

Author
ZHANG, Zheng
 

Source
————————————————————分割线————————————————————
思路:很简单的dfs问题,但是本屌一提交就time limited,求教了大神之后,发现需要剪枝,不然就会超时;
这题测试数据好像有点问题,用%c各种wa,换成%s存储后立马ac
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int n,m,t;
int dir[4][2]={{-1,0},{0,-1},{1,0},{0,1}};
char map[10][10];
int sx,sy,ex,ey;
int ok;
void dfs(int x,int y,int cnt)
{
	int fx,fy,i,temp;
	if(cnt==t)
	{
		if(x==ex&&y==ey)
		ok=1;
		return ;
	}
	if(ok) return ;
	temp=abs(x-ex)+abs(y-ey)-abs(cnt-t);     //奇偶剪枝 
	if(temp>0||temp&1) return ;
	for(i=0;i<4;i++)
	{
		fx=x+dir[i][0];
		fy=y+dir[i][1];
		if(fx>=0&&fx<n&&fy>=0&&fy<m&&map[fx][fy]!='X')
		{
			map[fx][fy]='X';
			dfs(fx,fy,cnt+1);
			map[fx][fy]='.';
		}
	}
}
int main()
{
	int wall,i,j;
	while(scanf("%d%d%d",&n,&m,&t),n||m||t)
	{
		wall=0;
		for(i=0;i<n;i++)
		{
			getchar();
			scanf("%s",map[i]);
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='S')
				{
					sx=i;
					sy=j;
				}
				else if(map[i][j]=='D')
				{
					ex=i;
					ey=j;
				}
				else if(map[i][j]=='X')
				{
					wall++;
				}
			}
		}
		if(n*m-wall<=t) printf("NO\n");
		else
		{
			ok=0;
			map[sx][sy]='X';
			dfs(sx,sy,0);
			if(ok) printf("YES\n");
			else printf("NO\n");
		} 
	}
	return 0;
}

抱歉!评论已关闭.