现在的位置: 首页 > 综合 > 正文

hdoj1063

2014年09月05日 ⁄ 综合 ⁄ 共 1672字 ⁄ 字号 评论关闭

Exponentiation

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4187    Accepted Submission(s): 1122


Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 

 


Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
 


Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
 


Sample Input
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
 


Sample Output
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
 


Source
 


Recommend
PrincetonBoy

import java.util.Scanner;
import java.math.*;


public class Main {


    public static void main(String args[]) {
        Scanner in = new Scanner(System.in);
        while (in.hasNext()) {
            BigDecimal a;
            a = in.nextBigDecimal();
            int n = in.nextInt();
            a = a.pow(n);
            a = a.stripTrailingZeros();
            String str = a.toPlainString();
            if (str.charAt(0) == '0') {
                str = str.substring(1);
            }
            System.out.println(str);
        }
    }
}
【上篇】
【下篇】

抱歉!评论已关闭.