现在的位置: 首页 > 综合 > 正文

POJ2377 Bad Cowtractors【Kruskal】【求最大生成树】

2015年06月17日 ⁄ 综合 ⁄ 共 2440字 ⁄ 字号 评论关闭
Bad Cowtractors

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 10933
Accepted: 4614

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns.
Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that
it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of
connections will look like a "tree".


Input

* Line 1: Two space-separated integers: N and M 


* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.


Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.


Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17


Sample Output

42


Hint

OUTPUT DETAILS: 
The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.


Source

USACO 2004 December Silver


题目大意:Bessie要在John的N个谷仓之间修路,John要求用尽可能少的路使得所有谷仓都能

联通,并且总距离最短,但是他又不想给Bessie钱。Bessie已经意识到John可能不给他钱,所

以他就想把这个工程做的最糟糕并且不让John发现。他决定用尽可能少的路使得所有谷仓都能

联通,但是要使总距离尽可能长。求这个可能的总距离。如果不能使得所有谷仓都联通,则输

出"-1"。

思路:和最小生成树的求法类似,这里使边的权值尽可能大。用Kruskal算法来做,排序的时候,

将边从大到小排序。因为Kruskal算法过程中要先判断两点是否联通,而且边是从大到小排序,所

以如果两点间有重边,则优先选择大的加入生成树中。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN = 1100;
const int MAXM = 40040;
struct EdgeNode
{
    int from;
    int to;
    int w;
}Edges[MAXM];

int father[MAXN];

int find(int x)
{
    if(x != father[x])
        father[x] = find(father[x]);
    return father[x];
}

int cmp(EdgeNode a,EdgeNode b)
{
    return a.w > b.w;
}

void Kruskal(int N,int M)
{
    sort(Edges,Edges+M,cmp);
    int ans = 0,Count = 0;

    for(int i = 0; i < M; ++i)
    {
        int u = find(Edges[i].from);
        int v = find(Edges[i].to);
        if(u != v)
        {
            ans += Edges[i].w;
            father[v] = u;
            Count++;
            if(Count == N-1)
                break;
        }
    }
    if(Count == N-1)
        cout << ans << endl;
    else
        cout << "-1" << endl;
}
int main()
{
    int N,M;
    while(~scanf("%d%d",&N,&M))
    {
        for(int i = 1; i <= N; ++i)
            father[i] = i;
        for(int i = 0; i < M; ++i)
        {
            scanf("%d%d%d",&Edges[i].from, &Edges[i].to, &Edges[i].w);
        }
        Kruskal(N,M);
    }

    return 0;
}

抱歉!评论已关闭.