现在的位置: 首页 > 综合 > 正文

POJ 题目1252Euro Efficiency(背包变形,允许找零)

2015年12月11日 ⁄ 综合 ⁄ 共 3102字 ⁄ 字号 评论关闭
Euro Efficiency
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 3359   Accepted: 1453

Description

On January 1st 2002, The Netherlands, and several other European countries abandoned their national currency in favour of the Euro. This changed the ease of paying, and not just internationally. 
A student buying a 68 guilder book before January 1st could pay for the book with one 50 guilder banknote and two 10 guilder banknotes, receiving two guilders in change. In short:50+10+10-1-1=68. Other ways of paying were: 50+25-5-1-1, or 100-25-5-1-1.Either
way, there are always 5 units (banknotes or coins) involved in the payment process, and it 
could not be done with less than 5 units. 
Buying a 68 Euro book is easier these days: 50+20-2 = 68, so only 3 units are involved.This is no coincidence; in many other cases paying with euros is more efficient than paying with guilders. On average the Euro is more efficient. This has nothing to do,
of course, with the value of the Euro, but with the units chosen. The units for guilders used to be: 1, 2.5, 5, 10, 25, 50,whereas the units for the Euro are: 1, 2, 5, 10, 20, 50. 
For this problem we restrict ourselves to amounts up to 100 cents. The Euro has coins with values 1, 2, 5, 10, 20, 50 eurocents. In paying an arbitrary amount in the range [1, 100] eurocents, on average 2.96 coins are involved, either as payment or as change.
The Euro series is not optimal in this sense. With coins 1, 24, 34, 39, 46, 50 an amount of 68 cents can be paid using two coins.The average number of coins involved in paying an amount in the range [1, 100] is 2.52. 
Calculations with the latter series are more complex, however. That is, mental calculations.These calculations could easily be programmed in any mobile phone, which nearly everybody carries around nowadays. Preparing for the future, a committee of the European
Central Bank is studying the efficiency of series of coins, to find the most efficient series for amounts up to 100 eurocents. They need your help. 
Write a program that, given a series of coins, calculates the average and maximum number of coins needed to pay any amount up to and including 100 cents. You may assume that both parties involved have sufficient numbers of any coin at their disposal. 

Input

The first line of the input contains the number of test cases. Each test case is described by 6 different positive integers on a single line: the values of the coins, in ascending order. The first number is always 1. The last number is less than 100. 

Output

For each test case the output is a single line containing first the average and then the maximum number of coins involved in paying an amount in the range [1, 100]. These values are separated by a space. As in the example, the average should always contain
two digits behind the decimal point. The maximum is always an integer. 

Sample Input

3
1 2 5 10 20 50
1 24 34 39 46 50
1 2 3 7 19 72

Sample Output

2.96 5
2.52 3
2.80 4

Source

英语读着真蛋疼,恰逢心情不好==
题目大意:就是输入6个钱数,让求100之内的钱数的凑的最小个数中的最大个数,以及这些个数的和,,,,读英语读的汉语都说得语无伦次了,大概就这么个意思上代码~~
ac代码
#include<stdio.h>
#include<string.h>
#define min(a,b) (a>b?b:a)
#define max(a,b) (a>b?a:b)
#define maxn 5005
#define INF 0xfffffff
int a[110],dp[maxn];//dp[n]表示当钱数的n时,最小过程数
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i,j,ans=0;
		double sum=0;
		for(i=0;i<6;i++)
			scanf("%d",&a[i]);
		for(i=0;i<maxn;i++)
			dp[i]=INF;
		dp[0]=0;
		for(i=0;i<6;i++)//不找零
		{
			for(j=a[i];j<maxn;j++)
			{
				dp[j]=min(dp[j],dp[j-a[i]]+1);
			}
		}
		for(i=0;i<6;i++)//找零
		{
			for(j=maxn-a[i];j>0;j--)
			{
				dp[j]=min(dp[j],dp[j+a[i]]+1);
			}
		}
		for(i=1;i<=100;i++)
		{
			ans=max(ans,dp[i]);
			sum+=dp[i];
		}
		printf("%.2lf %d\n",sum/100,ans);
	}
}

抱歉!评论已关闭.