现在的位置: 首页 > 综合 > 正文

HDOJ How Many Tables 1213(入门级并查集)

2017年10月17日 ⁄ 综合 ⁄ 共 1680字 ⁄ 字号 评论关闭

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15105    Accepted Submission(s): 7376

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
2 4
 

Author
Ignatius.L
 

Source
题目大意:Ignatius过生日邀请朋友聚会,但是互相不认识的人不能坐到一张桌子。如果A认识B,B认识C,那么A和C就算认识,可以坐到一起。
                  测试数据有T组,每组测试数据第一行有两个数据N,M。N表示有N个人,M表示下面有M行。
典型并查集问题,可以用来作为入门学习。。。。
#include<stdio.h>
#include<stdlib.h>
int s[1010];
int find(int x)
{
	while(s[x]!=x)
	x=s[x];
	return x;
}
void merge(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
	s[fx]=fy;
}
int main()
{
	void merge(int x,int y);
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int a,b,i,n,m,count=0;
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
		 s[i]=i;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&a,&b);
			merge(a,b);
		}
		for(i=1;i<=n;i++)
		  if(s[i]==i)
		   count++;
		printf("%d\n",count);
	}
	return 0;
} 

抱歉!评论已关闭.