现在的位置: 首页 > 综合 > 正文

HDU/HDOJ 3592 差分约束 World Exhibition 2010年多校联合第15场

2017年11月23日 ⁄ 综合 ⁄ 共 2764字 ⁄ 字号 评论关闭

 

World Exhibition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 572    Accepted Submission(s): 267

Problem Description
Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered
1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes
which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.

 

Input
First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y.

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.

 

Output
For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.
 

Sample Input
1 4 2 1 1 3 8 2 4 15 2 3 4
 

Sample Output
19
 

Author
alpc20
 

Source
 
这个题很明显的,题目就告诉了我们一个不等式关系
解不等式就是我们的答案。
对于熟悉差分约束系统的童鞋而言,应该比较水,可以快速AC
 
我比较巨弱,先开始连边的方向连反了,样例都不过。
然后我在纸上画了画,把边的方向又拨回来。
于是提交,果断AC
 
我的代码:
#include<stdio.h>
#include<algorithm>
#include<queue>
#include<vector>
#define inf 99999999

using namespace std;
struct node
{
	int v;
	int len;
};
vector<node>map[1005];
int n,x,y;

void init()
{
	int i;
	for(i=0;i<1005;i++)
		map[i].clear();
}

int spfa(int s)
{
	int i,dis[1005];
	bool used[1005];
	int num[1005];
	queue<int>q;
	for(i=0;i<1005;i++)
		dis[i]=inf;
	memset(num,0,sizeof(num));
	memset(used,0,sizeof(used));
	dis[s]=0;
	used[s]=true;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		used[u]=false;
		for(i=0;i<map[u].size();i++)
		{
			node p=map[u][i];
			if(dis[p.v]>dis[u]+p.len)
			{
				dis[p.v]=dis[u]+p.len;
				if(!used[p.v])
				{
					used[p.v]=true;
					num[p.v]++;
					if(num[p.v]>n)
						return -1;
					q.push(p.v);
				}
			}
		}
	}
	if(dis[n]>=inf)
		return -2;
	else
		return dis[n];
}

int main()
{
	int i,t,a,b,l,ans;
	node p;
	scanf("%d",&t);
	while(t--)
	{
		init();
		scanf("%d%d%d",&n,&x,&y);
		for(i=1;i<=x;i++)
		{
			scanf("%d%d%d",&a,&b,&l);
			p.v=b;
			p.len=l;
			map[a].push_back(p);
		}
		for(i=1;i<=y;i++)
		{
			scanf("%d%d%d",&a,&b,&l);
			p.v=a;
			p.len=-l;
			map[b].push_back(p);
		}
		ans=spfa(1);
		printf("%d\n",ans);
	}
	return 0;
}

抱歉!评论已关闭.