现在的位置: 首页 > 综合 > 正文

ZOJ 2702 Unrhymable Rhymes 贪心

2017年11月23日 ⁄ 综合 ⁄ 共 2554字 ⁄ 字号 评论关闭

贪心,能凑成一组就算一组

Unrhymable Rhymes


Time Limit: 10 Seconds      Memory Limit: 32768 KB      Special Judge


An amateur poet Willy is going to write his first abstract poem. Since abstract art does not give much care to the meaning of the poem, Willy is planning to impress listeners with unusual
combinations of words. He prepared n lines of the future poem, but suddenly noticed that not all of them rhyme well.

Though abstractionist, Willy strongly respects canons of classic poetry. He is going to write the poem that would consist of quatrains. Each quatrain consists of two pairs of rhymed lines.
Therefore there can be four types of quatrains, if we denote rhymed lines with the same letter, these types are “AABB”, “ABAB”, “ABBA” and “AAAA”.

Willy divided the lines he composed into groups, such that in each group any line rhymes with any other one. He assigned a unique integer number to each group and wrote the number of
the group it belongs next to each line. Now he wants to drop some lines from the poem, so that it consisted of correctly rhymed quatrains. Of course, he does not want to change the order of the lines.

Help Willy to create the longest poem from his material.

Input

There are mutilple cases in the input file.

The first line of each case contains n --- the number of lines Willy has composed (1 <= n <= 4000 ). It is followed by n integer numbers denoting the rhyme
groups that lines of the poem belong to. All numbers are positive and do not exceed 109 .

There is an empty line after each case.

Output

On the first line of the output file print k --- the maximal number of quatrains Willy can make. After that print 4k numbers --- the lines that should form the poem.

There should be an empty line after each case.

Sample Input

15
1 2 3 1 2 1 2 3 3 2 1 1 3 2 2

3
1 2 3

Sample Output

3
1 2 4 5
7 8 9 10
11 12 14 15

0


Source: Andrew Stankevich's Contest #9

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

const int maxn=4400;

int n;
vector<int> v[maxn];
vector<int> ans;

void init()
{
    for(int i=0; i<=n+10; i++) v[i].clear();
    ans.clear();
}

int a[maxn],b[maxn];

int main()
{
    bool first=true;
    while(scanf("%d",&n)!=EOF)
    {
        if(first) first=false;
        else putchar(10);

        init();
        for(int i=0; i<n; i++)
        {
            scanf("%d",a+i);
            b[i]=a[i];
        }
        sort(b,b+n);
        int m=unique(b,b+n)-b;
        int two=-1;
        for(int i=0;i<n;i++)
        {
            a[i]=lower_bound(b,b+m,a[i])-b;
            v[a[i]].push_back(i);
            int vas=v[a[i]].size();
            if(vas>=2)
            {
                if(two!=-1)
                {
                    if(two!=a[i])
                    {
                        ans.push_back(v[two][0]);
                        ans.push_back(v[two][1]);
                        ans.push_back(v[a[i]][0]);
                        ans.push_back(v[a[i]][1]);
                        /// clear
                        for(int j=0; j<=n+10; j++) v[j].clear();
                        two=-1;
                    }
                    else if(two==a[i]&&vas>=4)
                    {
                        for(int j=0;j<4;j++)
                        {
                            ans.push_back(v[a[i]][j]);
                        }
                        for(int j=0; j<=n+10; j++) v[j].clear();
                        two=-1;
                    }
                }
                else
                {
                    two=a[i];
                }
            }
        }
        printf("%d\n",(int)ans.size()/4);
        sort(ans.begin(),ans.end());
        for(int i=0,sz=ans.size();i<sz;i++)
        {
            printf("%d",ans[i]+1);
            if((i+1)%4==0) putchar(10);
            else putchar(32);
        }
    }
    return 0;
}

抱歉!评论已关闭.