现在的位置: 首页 > 综合 > 正文

HDOJ 4252 A Famous City 单调栈

2017年11月23日 ⁄ 综合 ⁄ 共 1898字 ⁄ 字号 评论关闭

单调栈: 维护一个单调栈

A Famous City

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1671    Accepted Submission(s): 644


Problem Description
After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows:
- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building,
or no buildings at all.
- measure the height of each building in that piece.
- write a program to calculate the minimum number of buildings.
Mr. B has finished the first two steps, the last comes to you.
 


Input
Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the
input numbers will be nonnegative and less than 1,000,000,000.
 


Output
For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.
 


Sample Input
3 1 2 3 3 1 2 1
 


Sample Output
Case 1: 3 Case 2: 2
Hint
The possible configurations of the samples are illustrated below:
 


Source
 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <stack>

using namespace std;

stack<int> stk;
int n;

int main()
{
    int cas=1;
    while(scanf("%d",&n)!=EOF)
    {
        int ans=0;
        while(!stk.empty()) stk.pop();
        for(int i=0;i<n;i++)
        {
            int x;
            scanf("%d",&x);
            if(stk.empty())
            {
                if(x!=0) stk.push(x);
                continue;
            }
            if(stk.top()==x) continue;
            else if(stk.top()<x) stk.push(x);
            else
            {
                bool flag=true;
                while(!stk.empty())
                {
                    if(stk.top()>x)
                    {
                        stk.pop(); ans++;
                    }
                    else if(stk.top()==x)
                    {
                        flag=false;
                        break;
                    }
                    else if(stk.top()<x)
                    {
                        if(x!=0) stk.push(x);
                        flag=false;
                        break;
                    }
                }
                if(flag)
                {
                    if(x!=0) stk.push(x);
                }
            }
        }
        ans+=stk.size();
        printf("Case %d: %d\n",cas++,ans);
    }
    return 0;
}

抱歉!评论已关闭.