现在的位置: 首页 > 综合 > 正文

HDOJ 1711 Number Sequence (kmp)

2018年01月12日 ⁄ 综合 ⁄ 共 1375字 ⁄ 字号 评论关闭

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7872 Accepted Submission(s): 3588

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

Sample Output
6 -1
最基本的kmp
kmp主要是要理解get_next函数
代码:
#include<stdio.h>
int a[1000005],b[10005];
int next[10005];
void get_next(int m)
{
    int i,j;
    i=0;
    j=-1;
    next[0]=-1;
    while(i<m)
    {
        if(b[i]==b[j]||j==-1)
        {
            ++i;
            ++j;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int kmp(int n,int m)
{
    int i=0,j=0;
    while(i<n)
    {
        if(j==-1||a[i]==b[j])
        {
            ++i;
            ++j;
        }
        else
            j=next[j];
        if(j==m)
        {
            return i-m+1;
        }
    }
    return -1;
}
int main()
{
    int T,m,n,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<n;++i)
            scanf("%d",&a[i]);
        for(i=0;i<m;++i)
            scanf("%d",&b[i]);
        get_next(m);
        printf("%d\n",kmp(n,m));
    }
    return 0;
}

抱歉!评论已关闭.