现在的位置: 首页 > 综合 > 正文

【KMP】 hdu4300 Clairewd’s message

2018年01月14日 ⁄ 综合 ⁄ 共 2219字 ⁄ 字号 评论关闭

Clairewd’s message

http://acm.hdu.edu.cn/showproblem.php?pid=4300



Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion
table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action,
she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering
the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 


Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the
text is complete.
Hint

Range of test data:
T<= 100 ;
n<= 100000;

 


Output
For each test case, output one line contains the shorest possible complete text.
 


Sample Input
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 


Sample Output
abcdabcd qwertabcde

题意:截获了一段电文,电文至少含有密文(和明文),密文完整,明文可能不全甚至完全没有。现要求根据给出的匹配规则输出完整的电文(要求使电文最短)。

#include<cstdio>
#include<cstring>
using namespace std;
char s[100005],t[100005];
char match[30],table[30];
int next[100005],slen,tlen;
char cop[30];
void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    for(;t[i];)
        if(j==-1||t[i]==t[j])
        {
            ++i;++j;
            next[i]=j;
        }
        else j=next[j];
}
int kmp()
{
    int i=0,j=0;
    for(;i<slen&&j<tlen;)
    {
        if(j==-1||s[i]==table[t[j]-'a'])
        {
            i++;j++;
            if(i==slen)
                return j;
        }
        else
            j=next[j];
    }
    return 0;
}
int main()
{
    int cas;
    scanf("%d",&cas);
    for(;cas--;)
    {
        scanf("%s%s",match,t);
        strcpy(s,t+(strlen(t)+1)/2);
        slen=strlen(s);
        tlen=strlen(t);
        for(int i=0;i<26;++i)
            table[match[i]-'a']='a'+i;
        get_next();
        int k=kmp();
        printf("%s",t);
        for(int i=k;i<tlen-k;++i)
           printf("%c",table[t[i]-'a']);
        printf("\n");
    }
    return 0;
}

来源:http://blog.csdn.net/ACM_Ted/article/details/7823851

抱歉!评论已关闭.