现在的位置: 首页 > 综合 > 正文

【JAVA】Gary’s Calculator

2018年01月14日 ⁄ 综合 ⁄ 共 2234字 ⁄ 字号 评论关闭

Gary's Calculator

Problem Description
Gary has finally decided to find a calculator to avoid making simple calculational mistakes in his math exam. Unable to find a suitable calculator in the market with enough precision, Gary has designed a high-precision calculator himself. Can you help him to
write the necessary program that will make his design possible?

For simplicity, you only need to consider two kinds of calculations in your program: addition and multiplication. It is guaranteed that all input numbers to the calculator are non-negative and without leading zeroes.
 
Input
There are multiple test cases in the input file. Each test case starts with one positive integer N (N < 20), followed by a line containing N strings, describing the expression which Gary's calculator should evaluate. Each of the N strings might be a string
representing a non-negative integer, a "*", or a "+". No integer in the input will exceed 109.

Input ends with End-of-File.
 
Output
For each test case, please output one single integer (with no leading zeros), the answer to Gary's expression. If Gary's expression is invalid, output "Invalid Expression!" instead. Please use the format indicated in the sample output. 
 
SampleInput
3
100 + 600
3
20 * 4
2
+ 500
5
20 + 300 * 20
 
SampleOutput
Case 1: 700
Case 2: 80
Case 3: Invalid Expression!
Case 4: 6020

import java.io.*;
import java.util.*;
import java.math.*;
public class Main
{
    public static void main(String[] args)
    {
	int n,ti=1;
        char[][] ch=new char[25][];
        BigInteger[] q=new BigInteger[25];
        Scanner cin = new Scanner(new BufferedInputStream(System.in));
	BigInteger summ=BigInteger.valueOf(0),temp,ten=BigInteger.valueOf(10);
	for(boolean flag=false,tmt=false;cin.hasNext();flag=false,tmt=false)
	{
                int top=0;
                n=cin.nextInt();
		summ=BigInteger.valueOf(0);
		for(int i=0;i<n;++i)
		{
                        ch[i]=cin.next().toCharArray();
			if(flag)
			{
				if(ch[i][0]!='*'&&ch[i][0]!='+')
					tmt=true;
				flag=false;
			}
			else
			{
				if(ch[i][0]=='*'||ch[0][0]=='+')
					tmt=true;
				flag=true;
			}
		}
		System.out.printf("Case %d: ",ti++);
		if(tmt||(!flag))
		{
			System.out.printf("Invalid Expression!\n");
			continue;
		}
		for(int i=0;i<n;++i)
		{
			temp=BigInteger.valueOf(0);
			if(ch[i][0]!='*'&&ch[i][0]!='+')
			{
                                temp=new BigInteger(String.valueOf(ch[i]));
				//for(int j=0;j<strlen(ch[i]);++j)
				//	temp=temp.multiply(ten).add(BigInteger.valueOf(ch[i][j]-'0'));
				if(i-1>0&&(ch[i-1][0]=='*'))
					temp=temp.multiply(q[--top]);
				q[top++]=temp;
			}
		}
		for(--top;top>=0;--top)
			summ=summ.add(q[top]);
		System.out.println(summ.toString());
	}
    }
}

抱歉!评论已关闭.