现在的位置: 首页 > 综合 > 正文

POJ 1745 Divisibility

2018年01月15日 ⁄ 综合 ⁄ 共 1529字 ⁄ 字号 评论关闭
Divisibility
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9151   Accepted: 3187

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence:
17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16  
17 + 5 + -21 - 15 = -14  
17 + 5 - -21 + 15 = 58  
17 + 5 - -21 - 15 = 28  
17 - 5 + -21 + 15 = 6  
17 - 5 + -21 - 15 = -24  
17 - 5 - -21 + 15 = 48  
17 - 5 - -21 - 15 = 18  
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible
by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 

The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.
 

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible
 
直接递推做出来的
 
#include<cstdio>
#include<cstring>

using namespace std;

const int MAXN=111;

int d[12222][122];

int main()
{
	int N,K;
	int i,j,num,tmp;

	while(scanf("%d%d",&N,&K)==2)
	{
		memset(d,0,sizeof(d));
		d[0][0]=1;

		for(i=1;i<=N;i++)
		{
			scanf("%d",&num);
			num=(num%K+K)%K;
			for(j=0;j<=K;j++)
			{
				if(d[i-1][j]==true)
				{
					d[i][((j+num)%K+K)%K]=true;
					d[i][((j-num)%K+K)%K]=true;
				}
			}
		}

		if(d[N][0]==true)
			printf("Divisible\n");
		else
			printf("Not divisible\n");
	}

	return 0;
}

抱歉!评论已关闭.