现在的位置: 首页 > 综合 > 正文

hdu 3033 I love sneakers!

2018年01月15日 ⁄ 综合 ⁄ 共 2439字 ⁄ 字号 评论关闭

I love sneakers!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2404    Accepted Submission(s): 979

Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.


There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he
won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
 

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following
N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 

Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.
 

Sample Input
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66
 

Sample Output
255
 

Source
 

Recommend
gaojie

由于至少取1件,所以我们要想办法标记合法状态。

另外,要将原本分组背包中的两层循环调换下位置,否则只能将那组的一件物品放入背包。

trick:数据中有费用为0的物品,所以if不能交换位置,否则可能会将费用为0的物品放入背包两次。

#include<stdio.h>
#include<string.h>

#define MAXN 101

int c[11][MAXN],v[11][MAXN];
int len[11];

int dp[11][10001];

int main(void)
{
	int N,M,K;
//	freopen("d:\\in.txt","r",stdin);
	while(scanf("%d%d%d",&N,&M,&K)==3)
	{
		int i,j,k,a,b,d;
		memset(len,0,sizeof(len));
		for(i=1;i<=N;i++)
		{
			scanf("%d%d%d",&a,&b,&d);
			len[a]++;
			c[a][len[a]]=b;
			v[a][len[a]]=d;
		}
		memset(dp,-1,sizeof(dp));
		dp[0][0]=0;
		for(i=1;i<=K;i++)
		{

			if(!len[i])
				break;
			for(k=1;k<=len[i];k++)
			{
				for(j=M;j>=c[i][k];j--)
				{
					if( dp[i][j-c[i][k]]!=-1)
						dp[i][j]=dp[i][j-c[i][k]]+v[i][k]>dp[i][j]?dp[i][j-c[i][k]]+v[i][k]:dp[i][j];
					if( dp[i-1][j-c[i][k]]!=-1)
						dp[i][j]=dp[i-1][j-c[i][k]]+v[i][k]>dp[i][j]?dp[i-1][j-c[i][k]]+v[i][k]:dp[i][j];
				}
			}
		}
		int ok=1;
		if(i!=K+1)
		  ok=0;
		int tm=-1;
		for(i=0;i<=M && ok;i++)
			if(dp[K][i]>tm)
				tm=dp[K][i];
		if(ok && tm>=0)
			printf("%d\n",tm);
		else
			printf("Impossible\n");
	}
	return 0;
}
 

抱歉!评论已关闭.