现在的位置: 首页 > 综合 > 正文

Hdu 1238 Substrings

2018年01月15日 ⁄ 综合 ⁄ 共 1427字 ⁄ 字号 评论关闭

Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5022    Accepted Submission(s): 2253

Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the
number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
 

Output
There should be one line per test case containing the length of the largest string found.
 

Sample Input
2 3 ABCD BCDFF BRCD 2 rose orchid
 

Sample Output
2 2
 

Author
Asia 2002, Tehran (Iran), Preliminary
 

Recommend
Eddy

//找出长度最短的串来求子串,长度由大到小

#include<stdio.h>
#include<string.h>

char ch[101][101];

void sub(char *p1,char *p2)
{
    int d=strlen(p1);
    int i;
    for(i=0;i<d;i++)
    {
        p2[i]=p1[d-i-1];
    }
    p2[i]=0;
}

int main(void)
{
    int t;
    char c1[101];
    char c2[101];
    scanf("%d",&t);
    while(t--)
    {
        int n,i,j,k,min=101,tmp,ok=0,d;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%s",ch[i]);
            d=strlen(ch[i]);
            if(d<min)
            {
                tmp=i;
                min=d;
            }
        }
        for(i=min;i>=1 && !ok;i--)
        {
            for(j=0;j+i<=min && !ok;j++)
            {
                memcpy(c1,ch[tmp]+j,i);
                c1[j+i]=0;
                sub(c1,c2);
                for(k=1;k<=n;k++)
                {
                    if(strstr(ch[k],c1)==NULL && strstr(ch[k],c2)==NULL)
                        break;
                }
                if(k==n+1)
                {
                    ok=1;
                    printf("%d\n",i);
                }
            }
        }
        if(!ok)
            printf("0\n");

    }
    return 0;
}

抱歉!评论已关闭.