现在的位置: 首页 > 综合 > 正文

HDU 2289 Cup 二分求体积高度

2018年01月19日 ⁄ 综合 ⁄ 共 1366字 ⁄ 字号 评论关闭

Cup

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4311    Accepted Submission(s): 1359

Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?
The radius of the cup's top and bottom circle is known, the cup's height is also known.
Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.
Technical Specification
1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.
Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
Sample Input
1 100 100 100 3141562
Sample Output
99.999024
/*
hdoj 2289
二分吧 圆台体积公式 
*/

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;

const double PI=acos(-1.0);

double vol(double r,double R,double h,double H)
{
    double u=h/H*(R-r)+r;//高为h的圆台半径 
    return PI/3*(r*r+r*u+u*u)*h; //高为h圆台体积 
}

int main()
{
    int m,i;
    double low,up,mid,r,R,H,V,temp;
    
    scanf("%d",&m);
    while(m--)
    {
        scanf("%lf%lf%lf%lf",&r,&R,&H,&V);
        
        low=0;
        up=100; 
        while(up-low>1e-7)//自己尝试下精度 对否 
        {
            mid=(low+up)/2;
            temp=vol(r,R,mid,H);
            if(temp>V)
                up=mid;    
            else 
                low=mid;    
        }        
        printf("%.6lf\n",(up+low)/2);
            
    }
    return 0;
}

抱歉!评论已关闭.