现在的位置: 首页 > 综合 > 正文

HDU 1587 Flowers 简单题

2018年01月19日 ⁄ 综合 ⁄ 共 994字 ⁄ 字号 评论关闭

Flowers

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2901    Accepted Submission(s): 1936

Problem Description
As you know, Gardon trid hard for his love-letter, and now he's spending too much time on choosing flowers for Angel.
When Gardon entered the flower shop, he was frightened and dazed by thousands kinds of flowers.

"How can I choose!" Gardon shouted out.
Finally, Gardon-- a no-EQ man decided to buy flowers as many as possible.
Can you compute how many flowers Gardon can buy at most?
Input
Input have serveral test cases. Each case has two lines.
The first line contains two integers: N and M. M means how much money Gardon have.
N integers following, means the prices of differnt flowers.
Output
For each case, print how many flowers Gardon can buy at most.
You may firmly assume the number of each kind of flower is enough.
Sample Input
2 5 2 3
Sample Output
2
/*
HDU 1587 简单题 
*/
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int i,n,m,a,min;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		min=99999999;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a);	
			if(a<min)
				min=a;
		}
		printf("%d\n",m/min);
	}
	return 0;
} 

抱歉!评论已关闭.