现在的位置: 首页 > 综合 > 正文

HDU 1002 A + B Problem II 大数相加

2018年01月20日 ⁄ 综合 ⁄ 共 1464字 ⁄ 字号 评论关闭

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 204234    Accepted Submission(s): 39250

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
/*
1002 A + B Problem II
大数加法? 
*/
#include<iostream>
#include<cstring>
using namespace std;

char a[1001],b[1001];
int c[1001];

int main(){
    int i,j,n,k,z,len1,len2,t,num; 
    
        
        cin>>n;
        num=1; 
        while(num<=n)
        {
            scanf("%s %s",a,b);
            len1=strlen(a)-1;
            len2=strlen(b)-1;
            k=0;
            z=0;
            for(;len1>=0&&len2>=0;len1--,len2--)
            {
            
                t=(a[len1]-'0')+(b[len2]-'0')+z;
                c[k++]=t%10;
                z=t/10;
            }
            while(len1>=0)
            {
                t=a[len1]-'0'+z;
                c[k++]=t%10;
                z=t/10;
                len1--;    
            }
            while(len2>=0)
            {
                t=b[len2]-'0'+z;
                c[k++]=t%10;
                z=t/10;
                len2--;    
            }
            printf("Case %d:\n",num++);
            printf("%s + %s = ",a,b);
            for(i=k-1;i>=0;i--)
            {
                cout<<c[i];
            }
            printf("\n");
            if(num<=n)     printf("\n");
        }     
    return 0;
}

抱歉!评论已关闭.