现在的位置: 首页 > 综合 > 正文

HDU 2674 N!Again 大整数N!取余数

2018年01月20日 ⁄ 综合 ⁄ 共 989字 ⁄ 字号 评论关闭

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3243    Accepted Submission(s): 1745

Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
Output
For each case, output N! mod 2009
Sample Input
4 5
Sample Output
24 120
/*
2634 N!Again
output N! mod 2009
题目很机智啊 n<=10^9算N!肯定超时
2009=41*7*7
所以只要n>=41 
n!中必然有41,7,7 所以比是2009的倍数 取余数肯定为0; 
懒得打表 
*/
#include<iostream>
using namespace std;
int main(){
    int i,n; 
    long sum;
    while(cin>>n)
    {
        
        if(n<41)
        {    
            sum=1;
            for(i=1;i<=n;i++)
            {
                sum=sum*i;
                sum=sum%2009;
            }
        }
        else sum=0;
        cout<<sum<<endl;
    }     
    return 0;
}

抱歉!评论已关闭.