现在的位置: 首页 > 综合 > 正文

HDU 1051 Wooden Sticks 排序+最长递增

2018年01月20日 ⁄ 综合 ⁄ 共 2212字 ⁄ 字号 评论关闭

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12511    Accepted Submission(s): 5196

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to
prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden
sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one
or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output
2 1 3
题意是:将木棍放在机器里处理,第一根需要一分钟,剩余的如果大于等于前边放入的长度和重量,就不用费时间,否则需要一分钟,计算给出一组数的最少时间!用贪心算出最少降序序列个数!
/*
1051 Wooden Sticks
按照棍子排序 后面的比前面大则不需要调整
多关键字排序 先按长度排序从大到小排序 则长度可以忽略了 
之后就是求重量的最长递增序列 就是要改变的次数 
3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1
*/

#include<iostream>
#include<algorithm>
using namespace std;

struct stick{
    int len;
    int weight;
}; 

bool cmp(stick a,stick b)
{
    if (a.len!=b.len) return a.len>b.len;
        else if (a.weight!=b.weight) return a.weight>b.weight;
}

int main(){
    int i,n,m,c[5001],j,max;
    stick a[5001];
    cin>>n;
    while(n--)
    {    
        cin>>m;
        for(i=0;i<m;i++) 
            scanf("%d %d",&a[i].len,&a[i].weight);  
        sort(a,a+m,cmp);
  
        c[0]=1;    
        for(i=1;i<m;i++) {
            c[i]=1;
            for(j=0;j<i;j++)        
                if (a[i].weight>a[j].weight&&c[j]+1>c[i])
                    c[i]=c[j]+1;
            }
        max=c[0];    
        for(i=1;i<m;i++)
            if(c[i]>max) max=c[i];        
    
        printf("%d\n",max);        
        
    }
    return 0;
}

抱歉!评论已关闭.