现在的位置: 首页 > 综合 > 正文

HDU 1535 Invitation Cards 【SPFA + 链式前向星】

2018年01月21日 ⁄ 综合 ⁄ 共 3752字 ⁄ 字号 评论关闭

Invitation Cards

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2232    Accepted Submission(s): 1082

Problem Description
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards
with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation
to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait
until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting
and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program
that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

 

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops
including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive
integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
 

Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
 

Sample Input
2 2 2 1 2 13 2 1 33 4 6 1 2 10 2 1 60 1 3 20 3 4 10 2 4 5 4 1 50
 

Sample Output
46 210
/*
题目大意:求1到所有点的距离和+所有点到1的距离和 
建图后可求1到所有点距离,反向建图可得所有点到1的距离 
*/ 
第一次做SPFA算法,参考别人所得。
对于代码中,建图时写链式前向星和最大值初始化为0x3f3f3f3f的方式都是可以采取的。
#include<cstdio>
#include<cstring>
#include<queue>
#define N 1000002
#define inf 0x3f3f3f3f
using namespace std;
int n,m,cnt1,cnt2,head1[N],head2[N];
int dis[N],vis[N]; 
struct edge
{
    int to,w,next;
}e1[N],e2[N];

void init()
{
     cnt1=cnt2=0;
     memset(head1,-1,sizeof(head1));
     memset(head2,-1,sizeof(head2));
}

void addedge1(int i,int j,int w)
{
    e1[cnt1].to=j;
    e1[cnt1].w=w;
    e1[cnt1].next=head1[i];
    head1[i]=cnt1++;
}

void addedge2(int i,int j,int w)
{
    e2[cnt2].to=j;
    e2[cnt2].w=w;
    e2[cnt2].next=head2[i];
    head2[i]=cnt2++;
} 
 
void spfa1(int s)
{
    for(int i=1; i<=n; i++)
    {
        dis[i]=inf; 
        vis[i]=0;
    }
    queue<int>q;
   // while(!q.empty()) q.pop(); 
    dis[s]=0,vis[s]=1;
    q.push(s);
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        vis[x]=0;
        for(int k=head1[x]; k!=-1; k=e1[k].next)
        {
            int t=e1[k].to;
            if(dis[t]>dis[x]+e1[k].w)
            {
                dis[t]=dis[x]+e1[k].w;
                if(!vis[t])
                {
                    vis[t]=1;
                    q.push(t);
                }
            }
        }
    }
    return;
}

void spfa2(int s)
{
    for(int i=1; i<=n; i++)
    {
        dis[i]=inf;
        vis[i]=0;
    }
    queue<int>q;
   // while( !q.empty() ) q.pop();
    q.push(s);
    dis[s]=0,vis[s]=1;
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        vis[x]=0;
        for(int k=head2[x]; k!=-1; k=e2[k].next)
        {
            int t=e2[k].to;
            if(dis[t]>dis[x]+e2[k].w)
            {
                dis[t]=dis[x]+e2[k].w;
                if(!vis[t])
                {
                    vis[t]=1;
                    q.push(t);
                }
            }
        }
    }
    return;
}

int main()
{
    int T,sum,a,b,c;
    scanf("%d",&T);
    while(T--)
    {
        init(); 
        scanf("%d %d",&n,&m);
        while(m--)
        {
            scanf("%d %d %d",&a,&b,&c);
            addedge1(a,b,c);
            addedge2(b,a,c);
        }
        spfa1(1);
        sum=0;
        for(int i=2; i<=n; i++)
        { 
            sum+=dis[i];
        }
        spfa2(1);
        for(int i=2; i<=n; i++){
            sum+=dis[i];
        }
        printf("%d\n",sum);
    }
    return 0;
}
 

抱歉!评论已关闭.