现在的位置: 首页 > 综合 > 正文

hdu1372 Knight Moves (BFS)

2018年02月22日 ⁄ 综合 ⁄ 共 1993字 ⁄ 字号 评论关闭
Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that
the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing
the row on the chessboard.

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6

Sample Output
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
意思:就是象棋里的马跳的方式,直接模拟就行了。
#include<stdio.h>
#include<queue>
#include<string.h>
#include<iostream>
using namespace std;
typedef struct nn
{
    int x,y,step;
}node;
int vist[10][10],si,sj,di,dj,Step;
int dir[8][2]={{2,1},{2,-1},{-2,1},{-2,-1},{1,2},{-1,2},{1,-2},{-1,-2}};
void BFS()
{
    queue<node> Q;
    node q,p;
    int i,j,e;
    vist[si][sj]=1;
    q.y=si;q.x=sj; q.step=0;
    if(si==di&&sj==dj)
    {
        Step=0;
        return ;
    }
    Q.push(q);
    while(!Q.empty())
    {
        q=Q.front();
        Q.pop();
        for(e=0;e<8;e++)
        {
            i=q.y+dir[e][0];
            j=q.x+dir[e][1];
            if(i>=0&&i<8&&j>=0&&j<8&&vist[i][j]==0)
            {
                p.y=i;p.x=j;p.step=q.step+1;
                if(i==di&&j==dj)
                {
                    Step=p.step;
                    return ;
                }
                vist[i][j]=1;
                Q.push(p);
            }
        }
    }
}
int main()
{
    char ch1[5],ch2[5];
    while(scanf("%s %s",ch1,ch2)>0)
    {
        si=ch1[0]-'a'; sj=ch1[1]-'1';
        di=ch2[0]-'a';dj=ch2[1]-'1';
        memset(vist,0,sizeof(vist));
        BFS();
        printf("To get from %s to %s takes %d knight moves.\n",ch1,ch2,Step);
    }
}

抱歉!评论已关闭.