现在的位置: 首页 > 综合 > 正文

hdu1240 Asteroids! (BFS)

2018年02月22日 ⁄ 综合 ⁄ 共 3039字 ⁄ 字号 评论关闭
Problem Description
You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to
the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

Sample Input
START 1 O 0 0 0 0 0 0 END START 3 XXX XXX XXX OOO OOO OOO XXX XXX XXX 0 0 1 2 2 1 END START 5 OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO XXXXX XXXXX XXXXX XXXXX XXXXX OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO 0 0 0 4 4 4 END

Sample Output
1 0 3 4 NO ROUTE
题目意思:就是三维空间,每个输入的倒数第三行是起始位置,下一行是终点, 输出时第1个数是N,第二个是走的步数;
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
typedef struct nn
{
    int x,y,z,step;
}node;
int dir[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
char map[15][15][15];
int Step,sx,sy,sz,dx,dy,dz,flog,N;
void BFS()
{
    queue<node> Q;
    node q,p;
    int e,tx,ty,tz;
    if(sx==dx&&sy==dy&&sz==dz)
    {
        flog=1; Step=0;
        return ;
    }
    q.step=0;q.x=sx;q.y=sy;q.z=sz;
    Q.push(q);
    while(!Q.empty())
    {
        q=Q.front();
        Q.pop();
        for(e=0;e<6;e++)
        {
            tx=q.x+dir[e][0]; ty=q.y+dir[e][1]; tz=q.z+dir[e][2];
            if(tx>=0&&tx<N&&ty>=0&&ty<N&&tz>=0&&tz<N)
            if(map[tz][ty][tx]!='X')
            {
                p.step=q.step+1;p.x=tx;p.y=ty;p.z=tz;
                map[tz][ty][tx]='X';
                if(tx==dx&&ty==dy&&tz==dz)
                {
                    flog=1; Step=p.step;
                    return ;
                }
                Q.push(p);
            }
        }
    }
}
int main()
{
    int x,y,z;
    char str[10],ch[10];
    while(scanf("%s %d",str,&N)>0)
    {
        for(z=0;z<N;z++)
        for(y=0;y<N;y++)
        {
            getchar();
            scanf("%s",map[z][y]);
        }
        scanf("%d%d%d",&sx,&sy,&sz);
        scanf("%d%d%d",&dx,&dy,&dz);
        getchar();
        scanf("%s",ch);
        flog=0;
        BFS();
        if(flog==1)
        printf("%d %d\n",N,Step);
        else
        printf("NO ROUTE\n");
    }
}

抱歉!评论已关闭.