现在的位置: 首页 > 综合 > 正文

POJ1456Supermarket(贪心+优先队列)

2018年02月22日 ⁄ 综合 ⁄ 共 2757字 ⁄ 字号 评论关闭
Supermarket
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9103   Accepted: 3891

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time
for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is
Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts
at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 


Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product.
White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

Source

题意:

超市里有n个产品要卖,每个产品都有一个截至时间dx(从开始卖时算起),只有在这个截至时间之前才能卖出并且获得率润dy。
有多个产品,所有可以有不同的卖出顺序,每卖一个产品要占用1个单位的时间,问最多能卖出多少利润。
解题:把产品按最后期限从大到小排,然后从最大的那个期限时间往前一天一天推,如果当前天的期限产品没有完全卖出,就放到前一天期限,和前一天最后期限的产品一走卖,利润大的就先卖。没有卖出的又放到前一天去卖,这样从大期限往小期限推,因为小期限的产品不可能在大期限时间去卖,而大期限的产品可以在小的期限去卖。
#include<stdio.h>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
#define N 10005
typedef struct nnn
{
    int p,d;
}node;
typedef struct nn
{
    int p;
    friend bool operator<(struct nn a,struct nn b)//优先队列值从大到小取
    {
        return a.p<b.p;
    }
}INT;
node ans[N];
int cmp(node a,node b)//最后期限从大到小排
{
    return a.d>b.d;
}
int solve(int n,int l)
{
    int maxp=0,tl,d,i,maxd;
    priority_queue<INT>q;
    INT pp;
    i=0;
    for(maxd=ans[0].d; maxd>0;maxd--)
    {
        for( ;i<n&&maxd<=ans[i].d; i++)
        {
            pp.p=ans[i].p; q.push(pp);
        }
        tl=0;
        while(!q.empty()&&tl<l)
        {
            pp=q.top(); q.pop();
            maxp+=pp.p; tl++;
        }
    }
    return maxp;
}
int main()
{
    int n,l,i;

    while(scanf("%d",&n)>0)
    {
        for( i=0;i<n;i++)
            scanf("%d%d",&ans[i].p,&ans[i].d);
        if(n==0)
        {
            printf("0\n"); continue;
        }
        sort(ans,ans+n,cmp);
        printf("%d\n",solve(n,1));
    }
}

抱歉!评论已关闭.