现在的位置: 首页 > 综合 > 正文

hdu1540Tunnel Warfare (线段树,单点更新)

2018年02月22日 ⁄ 综合 ⁄ 共 2118字 ⁄ 字号 评论关闭
Problem Description
During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village
was directly connected with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration
of connection must be done immediately!

Input
The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event.

There are three different events described in different format shown below:

D x: The x-th village was destroyed.

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.

R: The village destroyed last was rebuilt.

Output
Output the answer to each of the Army commanders’ request in order on a separate line.

Sample Input
7 9 D 3 D 6 D 5 Q 4 Q 5 R Q 4 R Q 4

Sample Output
1 0 2 4
#include<stdio.h>
#define N 50000
struct node
{
    int llen,rlen;
}tree[4*N];
void builde(int l,int r,int k)
{
    int m=(l+r)/2;
    tree[k].llen=tree[k].rlen=r-l+1;
    if(l==r) return ;
    builde(l,m,k*2);
    builde(m+1,r,k*2+1);
}
void updata(int l,int r,int k,int id,int flog)
{
    int m=(l+r)/2;
    if(l==r)
    {
        tree[k].llen=tree[k].rlen=flog;
        return ;
    }
    if(id<=m) updata(l,m,k*2,id,flog);
    else updata(m+1,r,k*2+1,id,flog);
    tree[k].llen=tree[k*2].llen;
    tree[k].rlen=tree[k*2+1].rlen;
    if(tree[k].llen==m-l+1)
        tree[k].llen+=tree[k*2+1].llen;
    if(tree[k].rlen==r-m)
        tree[k].rlen+=tree[k*2].rlen;
}
int len,R,L;
void query(int l,int r,int k,int id)
{
    int m=(l+r)/2;
    if(l==r)
    {
        if(tree[k].llen)R=L=1;
        else R=L=0;
        len=tree[k].llen;
        return ;
    }
    if(id<=m)
    {
        query(l,m,k*2,id);
        if(R) len+=tree[k*2+1].llen;
        if(tree[k*2+1].llen<r-m) R=0;
    }
    else
    {
        query(m+1,r,k*2+1,id);
        if(L) len+=tree[k*2].rlen;
        if(tree[k*2].rlen<m-l+1) L=0;
    }
}
int main()
{
    int n,m,id,s[N+5],sn;
    char ch[5];
    while(scanf("%d%d",&n,&m)>0)
    {
        builde(1,n,1);sn=0;
        while(m--)
        {
            scanf("%s",ch);
            if(ch[0]=='D')
            {
                scanf("%d",&id); s[++sn]=id;
                updata(1,n,1,id,0);
            }
            else if(ch[0]=='R')
            {
                if(sn)
                updata(1,n,1,s[sn],1),sn--;
            }
            else
            {
                scanf("%d",&id);
                query(1,n,1,id);
                printf("%d\n",len);
            }
        }
    }
}

抱歉!评论已关闭.