现在的位置: 首页 > 综合 > 正文

hdu2767Proving Equivalences(强连通,缩点)

2018年02月22日 ⁄ 综合 ⁄ 共 2753字 ⁄ 字号 评论关闭
Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the
four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a
lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input
2 4 0 3 2 1 2 1 3

Sample Output
4 2
题意:给出n个点和m条边,问最少须添加多少个边,使得任意两点间能互通。给出的m条边是有向的。
解题:先求出强连通分量kk个,并把每个强连通重新编号为1至kk。再计算出新点的入度数与出度数,最终须要添加的边数就是 入度数为0的个数与出度数为0的个数之间最大的数。
#include<stdio.h>
#include<iostream>
#include<vector>
using namespace std;

vector<int>map[20005];
int stack[20005],top,f[20005];
int ind[20005],outd[20005];
int low[20005],dfn[20005],vist[20005],deep,qlt[20005],kk;

void init(int n)//初始化
{
    for(int i=1; i<=n; i++)
    {
         map[i].clear(); f[i]=0;
         vist[i]=0;  ind[i]=0; outd[i]=0;
    }
    top=0; deep=0; kk=0;
}
void dfs(int v)//求出每个强连通分量
{
    deep++; vist[v]=1;
    low[v]=dfn[v]=deep;
    stack[++top]=v; f[v]=1;
    int len=map[v].size();
    for(int i=0; i<len; i++)
    {
        int u=map[v][i];
        if(vist[u]==0){
            dfs(u);
          low[v]=(low[v]<low[u])?low[v]:low[u];
        }
        else  if(f[u])
         low[v]=(low[v]<dfn[u])?low[v]:dfn[u];
    }
    if(low[v]==dfn[v])
    {
        kk++;
        while(stack[top]!=v){
            qlt[stack[top]]=kk;//一个强连通分量看成一个整体点kk,把每个强连通分量连续编号为1~kk
            f[stack[top--]]=0;
        }
        qlt[stack[top]]=kk;f[stack[top--]]=0;
    }
}
int main()
{
    int t,n,m,v,u;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init(n);
        while(m--)
        {
            scanf("%d%d",&v,&u);
            map[v].push_back(u);
        }
        for(int i=1; i<=n; i++)
        if(vist[i]==0)
            dfs(i);
        if(kk==1)
        {
            printf("0\n"); continue;
        }
        for( v=1; v<=n; v++)
        {
                int k=map[v].size();
                for(int e=0; e<k; e++)
                {
                     u=map[v][e];
                    if(qlt[u]==qlt[v])continue;//当从v出发到达u,而u与v在同一强连通内部点
                    ind[qlt[u]]=1; outd[qlt[v]]=1;
                }
        }
        int ink=0,outk=0;
        for(int j=1; j<=kk; j++)//新点编号
        {
            if(ind[j]==0)ink++;
            if(outd[j]==0)outk++;
        }
        printf("%d\n",ink>outk?ink:outk);
    }
}

抱歉!评论已关闭.