现在的位置: 首页 > 综合 > 正文

POJ2031Building a Space Station (最小生成树之prim)

2018年02月22日 ⁄ 综合 ⁄ 共 3858字 ⁄ 字号 评论关闭
Problem Description
You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.

The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is
quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or
(3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least
three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with
the shortest total length of the corridors.

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form
a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.

Input
The input consists of multiple data sets. Each data set is given in the following format.

n
x1 y1 z1 r1
x2 y2 z2 r2
...
xn yn zn rn

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after
the decimal point. Values are separated by a space character.

Each of x, y, z and r is positive and is less than 100.0.

The end of the input is indicated by a line containing a zero.

Output
For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.

Sample Input
3 10.000 10.000 50.000 10.000 40.000 10.000 50.000 10.000 40.000 40.000 50.000 10.000 2 30.000 30.000 30.000 20.000 40.000 40.000 40.000 20.000 5 5.729 15.143 3.996 25.837 6.013 14.372 4.818 10.671 80.115 63.292 84.477 15.120 64.095 80.924 70.029 14.881 39.472 85.116 71.369 5.553 0

Sample Output
20.000 0.000 73.834
题目大意:
给出球心的位置(x,y,z)和半径(r),如果两球相离那么两球之间的距离是两球心间的距离,否则两球之间的距离为0.要求所有的点都相连并输出最小的距离和。
如果知道了题意那么就好做了,其实就是求最小生成树的问题!!
#include<stdio.h>
#include<math.h>
typedef struct nn
{
    double x,y,z,r,dist;
}NODE;
NODE node[105];
double map[105][105],INF=10000000.0;
int n,s[105];
void first()
{
    for(int i=1;i<=n;i++)
    {
        s[i]=0; node[i].dist=INF;
        for(int j=i+1;j<=n;j++)
        map[i][j]=map[j][i]=INF;
    }
}
void count_dist(NODE a,NODE b,int i,int j)
{
    double d;
    d=sqrt(pow(a.x-b.x,2)+pow(a.y-b.y,2)+pow(a.z-b.z,2));
    if(d>a.r+b.r)
    map[i][j]=map[j][i]=d-a.r-b.r;
    else
    map[j][i]=map[i][j]=0;
}
void count()
{
    for(int i=1;i<=n;i++)
    for(int j=i+1;j<=n;j++)
    count_dist(node[i],node[j],i,j);
}
double Prim(int m)
{
    int tm=m,k=1;
    double min,sum;
    s[m]=1;sum=0;
    for(int i=2;i<=n;i++)
    {
        min=INF;
        for(int j=1;j<=n;j++)
        if(s[j]==0)
        {
            if(node[j].dist>map[tm][j])
            node[j].dist=map[tm][j];
            if(min>node[j].dist)
            {
                min=node[j].dist; m=j;
            }
        }
        if(s[m]==0)
        {
            k++;s[m]=1; sum+=min;tm=m;
        }
    }
    if(k==n)
    return sum;
    return 0.0;
}
int main()
{
    while(scanf("%d",&n)>0&&n)
    {
        for(int i=1;i<=n;i++)
        scanf("%lf%lf%lf%lf",&node[i].x,&node[i].y,&node[i].z,&node[i].r);
        first();
        count();
        printf("%.3f\n",Prim(1));
    }
}

抱歉!评论已关闭.