现在的位置: 首页 > 综合 > 正文

hdu2602Bone Collector (简箪01背包)

2018年02月22日 ⁄ 综合 ⁄ 共 1366字 ⁄ 字号 评论关闭
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output
14
题目意思:有T组,每组有三行,第一行有两个数n(骨头数)和包的总体积,第二行是每个骨头价值,第三行是每个骨头的占用体积。输出要求背包能装最大的价值。
#include<stdio.h>
#define N 1010
struct nn
{
    int w,usev;
}bone[N];
int dp[N],V;
int max(int a,int b){return a>b?a:b;}
void zeroonepack(int use,int w)
{
    for(int v=V;v>=use;v--)
    dp[v]=max(dp[v],dp[v-use]+w);
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&V);
        for(int i=1;i<=n;i++)
        scanf("%d",&bone[i].w);
        for(int i=1;i<=n;i++)
        scanf("%d",&bone[i].usev);
        for(int i=0;i<=V;i++)
            dp[i]=0;
        for(int i=1;i<=n;i++)
        zeroonepack(bone[i].usev,bone[i].w);
        printf("%d\n",dp[V]);
    }
}

抱歉!评论已关闭.