现在的位置: 首页 > 综合 > 正文

CD(二分)

2018年02月22日 ⁄ 综合 ⁄ 共 1168字 ⁄ 字号 评论关闭
文章目录

Problem Description

Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?

Neither Jack nor Jill owns more than one copy of each CD.

Input

The input consists of a sequence of test cases. The first line of each test case contains two non-negative integers N and M, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed
by N lines listing the catalog numbers of the CDs owned by Jack in increasing order, and M more lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input
is terminated by a line containing two zeros. This last line is not a test case and should not be processed.

Output

For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.

Sample Input

3 3
1
2
3
1
2
4
0 0

Sample Output

2

 

#include<stdio.h>
__int64 a[1000005],k;
int main()
{
    int n,m,i,sum,h,d,mid;

    while(scanf("%d%d",&n,&m)>0&&(n!=0||m!=0))
    {
        sum=0;
        for(i=0;i<n;i++)
        scanf("%I64d",&a[i]);
        while(m--)
        {
            scanf("%I64d",&k);
            h=0;d=n-1;
            while(h<=d)
            {
                mid=(h+d)/2;
                if(a[mid]>k)
                d=mid-1;
                if(a[mid]<k)
                h=mid+1;
                if(a[mid]==k)
                {
                    sum++;break;
                }
            }
        }
        printf("%d\n",sum);
    }
}

 

【上篇】
【下篇】

抱歉!评论已关闭.