现在的位置: 首页 > 综合 > 正文

hdu1196(Lowest Bit)

2018年02月22日 ⁄ 综合 ⁄ 共 720字 ⁄ 字号 评论关闭
Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output
For each A in the input, output a line containing only its lowest bit.

Sample Input
26 88 0

Sample Output
2 8
#include<stdio.h>
#include<math.h>
int main()
{
    int a,b[1000],i,sum;
    while(scanf("%d",&a)==1&&a)
    {
        i=-1;
        while(a)
        {
            b[++i]=a%2;
            if(b[i])
            break;
            a/=2;
        }
        sum=0;
        for(i=i;i>=0;i--)
        sum+=(int)(b[i]*pow(2.0,i*1.0));

        printf("%d\n",sum);
    }
}

【上篇】
【下篇】

抱歉!评论已关闭.