现在的位置: 首页 > 综合 > 正文

C – Orders 字典序全排列

2018年04月15日 ⁄ 综合 ⁄ 共 1647字 ⁄ 字号 评论关闭
C - Orders

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this letter. During the day the stores
manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking. 

You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece
during the day. 

Input

Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn't exceed 200. 

Output

Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods. Each ordering of warehouses is
written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes. 

Sample Input

bbjd

Sample Output

bbdj
bbjd
bdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb

用函数交的。但是dfs递归应该也可以。


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;
char str[300];

int main()
{
    int i;
    while(scanf("%s",str)!=NULL)
    {
        int k=0;
        k = strlen(str);
        sort(str,str+k);
        do
        {
             puts(str);
        }while(next_permutation(str,str+k));
    }
    return 0;
}

抱歉!评论已关闭.