现在的位置: 首页 > 综合 > 正文

period

2018年04月15日 ⁄ 综合 ⁄ 共 1264字 ⁄ 字号 评论关闭

Period


Time Limit: 1000MS Memory limit: 65536K

题目描述

For each prefix of a given string S with N characters (each character has an
ASCII code between 97 and 126, inclusive), we want to know whether the prefix
is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K
> 1 (if there is one) such that the prefix of S with length i can be written as AK ,
that is A concatenated K times, for some string A. Of course, we also want to
know the period K.
 

输入

 The input file consists of several test cases. Each test case consists of two

lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.
The second line contains the string S. The input file ends with a line, having the
number zero on it.
 

输出

 For each test case, output “Test case #” and the consecutive test case

number on a single line; then, for each prefix with length i that has a period K >
1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.
 

示例输入

3
aaa
12
aabaabaabaab
0

示例输出

Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4


#include <stdio.h>
#include <string.h>
char S[1000001];
int next[1000001];
int main()
{
    int i=0,j,n;
    int t,p=0,l;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;

        scanf("%s",S);
        p++;
        printf("Test case #%d\n",p);
        i=0;
        j=-1;
        next[0] = -1;
        while(i<n)
        {
            if(j==-1||S[i]==S[j])
            {
                i++;
                j++;
                next[i]=j;
                t=i-j;
                if(i%t==0)
                {
                    if(i/t>1)
                        printf("%d %d\n",i,i/t);
                }
            }
            else
            {
                j=next[j];
            }
        }
        printf("\n");
        memset(S,0,n);

    }
    return 0;
}

抱歉!评论已关闭.