现在的位置: 首页 > 综合 > 正文

591 – Box of Bricks

2018年04月23日 ⁄ 综合 ⁄ 共 1600字 ⁄ 字号 评论关闭

  Box of Bricks 

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all
stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy
he wants to do this with the minimum number of bricks moved. Can you help?

Input 

The input consists of several data sets. Each set begins with a line containing the number n of
stacks Bob has built. The next line contains 
n numbers, the heights hi of
the 
n stacks. You may assume $1 Ÿ\le n \leŸ 50$ and$1 \leŸ h_i Ÿ\le 100$.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output 

For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'',
where 
k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input 

6
5 2 4 1 7 5
0

Sample Output 

Set #1
The minimum number of moves is 5.


这道题很水,就是说把n个不同高度的砖块排成同样的高度。问最少要移动多少砖块。

wa了一次,大家要注意UVa对输出的格式判的很严格,我因为多输出了一个回车就wa了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int a[60];
int main ()
{
    int n,i,t=1,ans=0,sum=0;
    while(cin>>n)
    {
        if (n==0) break;
        for (i=1; i<=n; i++)
        {
            scanf("%d",a+i);
            sum+=a[i];
        }
        int ave=sum/n;
        for (i=1; i<=n; i++)
            if (a[i]>ave)
                ans+=a[i]-ave;
        printf("Set #%d\n",t);
        printf("The minimum number of moves is %d.\n\n",ans);
        t++;
        ans=0;
        sum=0;
    }
    return 0;
}

抱歉!评论已关闭.