现在的位置: 首页 > 综合 > 正文

253 – Cube painting

2018年04月23日 ⁄ 综合 ⁄ 共 1808字 ⁄ 字号 评论关闭

 Cube painting 

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.

picture21

Figure 1.

Since a cube has 6 faces, our machine can paint a face-numbered cube in tex2html_wrap_inline126 different
ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a br, org. The tex2html_wrap_inline128 character
tex2html_wrap_inline130 ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds
to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 tex2html_wrap_inline134 , the one
changes into the other.

tex2html_wrap138 tex2html_wrap140

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the
remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

Output

The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.

Sample Input

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

Sample Output

TRUE
FALSE
FALSE

这道题看上去就很烦,做起来更烦。。我考虑到了大众做法,一一枚举。

后来我看了大牛的做法,厉害的很。orz。。

从原先的正方形当中选出3个面,从第二个正方形当中来找,如果在第二个正方形中找到两个互相对立的面和第一个中一样,那么把表机值改为1。同时将面赋值为‘0’。

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    char a[20];
    char c1[20],c2[20];
    while (cin>>a)
    {
        int i, j = 0;
        for (i = 0; i < 6; i++)
        {
            c1[i] = a[i];
            c2[i] = a[i+6];
        }
        int mrk;
        for (i = 0; i < 3; i++)
        {
            mrk = 0;
            for (j = 0; j < 6; j++)
            {
                if (c1[i]==c2[j] && c1[5-i]==c2[5-j])
                {
                    mrk = 1;
                    c2[j] = '0';
                    c2[5-j] = '0';
                    break;
                }
            }
            if (!mrk)    break;
        }
        if (!mrk)    cout << "FALSE" << endl;
        else    cout << "TRUE" << endl;
    }

    return 0;
}

抱歉!评论已关闭.