现在的位置: 首页 > 综合 > 正文

排序/查找 299 – Train Swapping

2018年04月23日 ⁄ 综合 ⁄ 共 2164字 ⁄ 字号 评论关闭

UVa OJ

 Train Swapping 

At an old railway station, you may still encounter one of the last remaining ``train swappers''. A train swapper is an employee of the railroad, whose sole job it is to rearrange the carriages of trains.

Once the carriages are arranged in the optimal order, all the train driver has to do, is drop the carriages off, one by one, at the stations for which the load is meant.

The title ``train swapper'' stems from the first person who performed this task, at a station close to a railway bridge. Instead of opening up vertically, the bridge rotated around a pillar in the center of the
river. After rotating the bridge 90 degrees, boats could pass left or right.

The first train swapper had discovered that the bridge could be operated with at most two carriages on it. By rotating the bridge 180 degrees, the carriages switched place, allowing him to rearrange the carriages
(as a side effect, the carriages then faced the opposite direction, but train carriages can move either way, so who cares).

Now that almost all train swappers have died out, the railway company would like to automate their operation. Part of the program to be developed, is a routine which decides for a given train the least number of
swaps of two adjacent carriages necessary to order the train. Your assignment is to create that routine.

Input Specification

The input contains on the first line the number of test cases (N). Each test case consists of two input lines. The first line of a test case contains an integer L, determining the length of the
train ( tex2html_wrap_inline30). The second line of a test case contains a permutation of the numbers 1 through L, indicating the current order
of the carriages. The carriages should be ordered such that carriage 1 comes first, then 2, etc. with carriage L coming last.

Output Specification

For each test case output the sentence: 'Optimal train swapping takes S swaps.' where S is an integer.

Example Input

3
3
1 3 2
4
4 3 2 1
2
2 1

Example Output

Optimal train swapping takes 1 swaps.
Optimal train swapping takes 6 swaps.
Optimal train swapping takes 1 swaps.

这道题其实就是求将一个乱序的数组排成顺序的需要多少步

之前有做过这种类型的题目,当时一开始用冒泡排序,可是数据太大,TLE了。

不过这里数据量小,用冒泡还是可以用的

不过还是要去学习一下归并排序和以及其延伸:求逆序对数。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int main ()
{
    int n,l,i,j;
    cin>>n;
    while(n--)
    {
        int t=0,a[55];
        cin>>l;
        for (i=0; i<l; i++)
            scanf("%d",a+i);
        for (i=0; i<l-1; i++)
            for (j=i+1; j<l; j++)
                if (a[i]>a[j])
                {
                    t++;
                    int temp;
                    temp=a[i];
                    a[i]=a[j];
                    a[j]=temp;
                }
        printf("Optimal train swapping takes %d swaps.\n",t);
    }
    return 0;
}

抱歉!评论已关闭.