现在的位置: 首页 > 综合 > 正文

排序/查找 340 – Master-Mind Hints

2018年04月23日 ⁄ 综合 ⁄ 共 3140字 ⁄ 字号 评论关闭

UVa OJ

Root :: AOAPC
I: Beginning Algorithm Contests (Rujia Liu)
 :: Volume 1. Elementary Problem Solving :: Sorting/Searching

 Master-Mind Hints 

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game,
the players agree upon the length N that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code tex2html_wrap_inline35 and a guess tex2html_wrap_inline37 ,
and are to determine the hint. A hint consists of a pair of numbers determined as follows.

match is a pair (i,j), tex2html_wrap_inline41 and tex2html_wrap_inline43 ,
such that tex2html_wrap_inline45 . Match (i,j) is called strong when i =j, and is called weak otherwise.
Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number
of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers,
which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to
be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would
normally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by
a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)

开始做排序 / 查找了。

先给出一个N。

然后是一组code。

之后是每组code_breaker。以N个0结束

每一个code_breaker和code进行对比,如果是相同位置数字相同,为强match,如果是不同位置数字相同,为弱match。

强match 的比较好判断。

弱match 可以用一个一位数组来记录每组code_breaker中出现了多少个【1~9】。然后和code比较即可。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<string.h>
using namespace std;
int main ()
{
    int t=1,n,i,j;
    int code[1050],breaker[1050];
    while(cin>>n)
    {
        int time_code[10]={0};
        if (n==0) break;
        printf("Game %d:\n",t);
        for (i=0; i<n; i++)
        {
            scanf("%d",code+i);
            time_code[code[i]]++;
        }
        while(1)
        {
            int s=0,p=0,time_breaker[10]={0};
            for (i=0; i<n; i++)
            {
                scanf("%d",breaker+i);
                time_breaker[breaker[i]]++;
                if (breaker[i]==code[i]) s++;
            }
            if (breaker[0]==0) break;
            for (i=1; i<10; i++)
                p+=time_code[i]<time_breaker[i]? time_code[i]:time_breaker[i];
            p-=s;
            printf("    (%d,%d)\n",s,p);
        }
        t++;
    }
    return 0;
}

抱歉!评论已关闭.