现在的位置: 首页 > 综合 > 正文

HDOJ–1061–Rightmost Digit

2018年04月24日 ⁄ 综合 ⁄ 共 978字 ⁄ 字号 评论关闭
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 


Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 


Output
For each test case, you should output the rightmost digit of N^N.
 


Sample Input
2 3 4
 


Sample Output
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 


Author
Ignatius.L
 
思路:不用高精度,只需以每一部得出的个位数继续相乘,最后取个位数即可。
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<time.h>
using namespace std;
char a[10000];
int main()
{
    long long int n;
    int i,m,q;
    int l,t,j,x,l2,b[50];
    scanf("%d",&t);
    while(t--)
    {
        m=0;
        scanf("%lld",&n);
        sprintf(a,"%lld",n);
        l=strlen(a);
        a[l-1]=a[l-1]-48;
        x=a[l-1];
        b[0]=x;
        for(i=1;;i++)
        {
            b[i]=b[i-1]*x;
            if(b[i]>=10)
                b[i]=b[i]%10;
            for(j=0;j<i;j++)
                if(b[i]==b[j])
                {
                    m=1;
                    q=i;
                }
            if(m)
                break;
        }
        x=n%q;
        if(x-1>=0)
            x=x-1;
        else
            x=q-1;
        printf("%d\n",b[x]);
    }
    return 0;
}

抱歉!评论已关闭.